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Welcome to STEP 7...

...the SIMATIC standard software for creating programmable logic control
programs in Ladder Logic, Function Block Diagram, or Statement List for SIMATIC
S7-300/400 stations.

About This Getting Started Manual

In this manual, you will get to know the basics of SIMATIC STEP 7. We will show
you the most important screen dialog boxes and the procedures to follow using
practical exercises, which are structured so that you can start with almost any
chapter.

Each section is split into two parts: a descriptive part, marked in gray, and a
process-oriented part, marked in green. The instructions start with an arrow in the
green margin and may be spread out over several pages, finishing in a full stop
and a box containing related topics.

Previous experience of working with the mouse, window handling, pull-down
menus, etc. would be useful, and you should preferably be familiar with the basic
principles of programmable logic control.

The STEP 7 training courses provide you with in-depth knowledge above and
beyond the contents of this Getting Started manual, teaching you how entire
automation solutions can be created with STEP 7.

Requirements for Working with the Getting Started Manual

In order to carry out the practical exercises for STEP 7 in this Getting Started
manual, you require the following:

e A Siemens programming device or a PC
 The STEP 7 software package and the authorization diskette

* A SIMATIC S7-300 or S7-400 programmable controller
(for Chapter 7 "Downloading and Debugging the Program").

Additional Documentation on STEP 7
e STEP 7 Basic Information
e STEP 7 Reference Information

After you have installed STEP 7, you will find the electronic manuals in the Start

menu under Simatic > Documentation or alternatively, you can order them from
any Siemens sales center. All of the information in the manuals can be called up
in STEP 7 from the online help.

Have fun and good luck!
SIEMENS AG

STEP 7 Getting Started
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1 Introduction to STEP 7

1.1 What You Will Learn

Using practical exercises, we will show you how easy it is to program in Ladder
Logic, Statement List, or Function Block Diagram with STEP 7.

Detailed instructions in the individual chapters will show you step-by-step the
many ways in which you can use STEP 7.

Creating a Program with Binary Logic

In Chapters 2 to 7, you will create a program with binary logic. Using the
programmed logic operations, you will address the inputs and outputs of your CPU

(if present).

The programming examples in the Getting Started manual are based, among other
things, on three fundamental binary logic operations.

The first binary logic operation, which you will program later on, is the AND
function. The AND function can be best illustrated in a circuit diagram using two

keys.
Key 1 Key2 If both Key 1 and Key 2
are pressed, the bulb
~ /g lights up.
_—

The second binary logic operation is the OR function. The OR function can also be
represented in a circuit diagram.

é Key 3

o If either key 3 or key 4
Key 4 E@ i_s pressed, the bulb
lights up.

STEP 7 Getting Started 1-1
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Introduction to STEP 7

The third binary logic operation is the memory element. The SR function reacts
within a circuit diagram to certain voltage states and passes these on accordingly.

Memory Element

+ _é’_R s)

If key S is pressed, the bulb lights up
and remains lit until key R is pressed.

1-2 STEP 7 Getting Started
A5E00069681-03



Introduction to STEP 7

1.2 Combining Hardware and Software

Using the STEP 7 software, you can create your S7 program within a project. The
S7 programmable controller consists of a power supply unit, a CPU, and input and

output modules (I/O modules).

The programmable logic controller (PLC) monitors and controls your machine with
the S7 program. The I/O modules are addressed in the S7 program via the

addresses.

Programming
device cable

Programming device

Transferring a program

Machine to be
controlled

CPU

Output module

Power supply module

Input module

STEP 7 Getting Started
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Introduction to STEP 7

1.3 Basic Procedure Using STEP 7

Before you create a project, you should know that STEP 7 projects can be created
in different orders.

Designing the solution to the automation task

Creating a project (Chapter 2)

Option 1 Option 2
Configuring the hardware Creating a program
(Chapter 6) (Chapters 3 to 5)
Creating a program Configuring the hardware
(Chapters 3to 5) (Chapter 6)

I 4

Transferring the program to the CPU and debugging
(Chapter 7)

If you are creating comprehensive programs with many inputs and outputs, we
recommend you configure the hardware first. The advantage of this is that STEP 7
displays the possible addresses in the Hardware Configuration Editor.

If you choose the second option, you have to determine each address yourself, depending
on your selected components and you cannot call these addresses via STEP 7.

In the hardware configuration, not only can you define addresses, but you can also change
the parameters and properties of modules. If you want to operate several CPUs, for
example, you have to match up the MPI addresses of the CPUs.

Since we are only using a small number of inputs and
outputs in the Getting Started manual, we will skip the —
hardware configuration for now and start with the
programming.

1-4 STEP 7 Getting Started
A5E00069681-03



Introduction to STEP 7

1.4 Installing STEP 7

Regardless of whether you want to start with programming or configuring
hardware, you first have to install STEP 7. If you are using a SIMATIC
programming device, STEP 7 is already installed.

When installing the STEP 7 software
on a programming device or PC
without a previously installed version of
STEP 7, note the software and
hardware requirements. You can find
these in the Readme.wri on the

STEP 7 CD under

<Drive>:\STEP 7 \Disk1.

If you need to install STEP 7 first,
insert the STEP 7 CD in the CD-ROM
drive now. The installation program
starts automatically. Follow the
instructions on the screen.

If the installation does not start
automatically, you can also find the
installation program on the CD-ROM
under

<Drive>:\STEP 7 \Disk1\setup.exe.

Once the installation is complete and
you have restarted the computer, the
SIMATIC Manager "SIMATIC Manager" icon will appear

E on your Windows desktop.

If you double-click the "SIMATIC Manager" icon following installation, the STEP 7 Wizard
will be started automatically.

You can find additional notes on installation in the
Readme.wri file on the STEP 7 CD under
<Drive>:\STEP 7 \Disk1\Readme.wri.

STEP 7 Getting Started 1-5
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2 The SIMATIC Manager

2.1  Starting the SIMATIC Manager and Creating a Project

The SIMATIC Manager is the central window which becomes active when STEP 7
is started. The default setting starts the STEP 7 Wizard, which supports you when
creating a STEP 7 project. The project structure is used to store and arrange all

the data and programs in order.

Within the project, data are stored in the
form of objects in a hierarchical structure

'[:I Blocks

S¥-Program

The SIMATIC station and the CPU
L contain the configuration and
parameter data of the hardware

= The S7 program comprises all the
blocks with the programs necessary for
controlling the machine

SIMATIC Manager

STEP 7 Wizard: "New Project” [<]
"% Introduction 104]

STEP 7 Wizard: "New Project”

“fou can create STEP 7 projects quickly and easily using
the STEP 7 Wizard, You can then start programming
imrnedistely.

.0 1 Click ane of the following optiars:

i )
‘ "_‘. 7 "Next"to creale your project step-by-step

5') " "Make" lo create your project accarding b the preview.

W Display wigard on starting the STMATIC Manager ‘ Ml

I Black Name Symbolic Name
-l SIMATIC 300 Station H0B
= Jl CPUZ12 IFM(1)
E=-{ar] 57 Programi(1)
424 Blocks

Cyele Execution

< Bt ’Make Cancel Help

STEP 7 Getting Started
A5E00069681-03

Double-click the SIMATIC Manager
icon. The STEP 7 Wizard is activated.

In the preview, you can toggle the
view of the project structure being
created on and off.

To move to the next dialog box, click
Next.

2-1



The SIMATIC Manager

IUEPTREE T At For the "Getting Started" sample
project, select CPU 314. The example
has been created in such a way that

EESV 312-84C020480

BES7 N3 D030 you can actually select the CPU you

BEST 314-14E04-0480
EES7 314-4E030480

BES7 315-1AFN3-04B0 have been Supplied with at any time.

BEST 315-24F03-04R0

The default setting for the MPI address
is 2.

Click Next to confirm the settings and
move to the next dialog box.

e Select the organization block OB1 (if
= this is not already selected).
Tie oy Select one of the programming
T Do 2 languages: Ladder Logic (LAD),
e —— Statement List (STL), or Function

Block Diagram (FBD).

Confirm your settings with Next.

STEP 7 Getting Started 2-2
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The SIMATIC Manager

Double-click to select the Suggested
“Zh What do you want to call your pm|ec‘l? 4(4] name |n the uPrOJeCt I’lame" f|e|d and
e (|GE‘“"g Stated J overwrite it with "Getting Started."
Existing projects: -

e .
- 5 Click Make to generate your new
Check. your new project in the previsw. . . .
Cick Make" o cedl e proes wih e dplayed project accordmg to the preview.
’J Gelting Started Block Name | Symbolic Name [
=18 SIMATIC 300 Station [RIT Cycle Execution
= Jl cPUB1AM)
=-{41] 57 Frogrami(1]
©£3 Blocks ——
< Back | Ilezt >(| Make )I Cancel Help

[o]

When you click the Make button, the SIMATIC Manager will open with the window for the
"Getting Started" project you have created. On the following pages, we will show you what
the created files and folders are for and how you can work effectively with them.

The STEP 7 Wizard is activated each time the program is started. You can deactivate this
default setting in the first dialog box for the Wizard. However, if you create projects without
the STEP 7 Wizard, you must create each directory within the project yourself.

You can find more information under
Help > Contents in the topic "Setting
Up and Editing the Project.”
STEP 7 Getting Started 2-3
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The SIMATIC Manager

2.2  The Project Structure in the SIMATIC Manager and How
to Call the Online Help

As soon as the STEP 7 Wizard is closed, the SIMATIC Manager appears with the
open project window "Getting Started.” From here, you can start all the STEP 7
functions and windows.

Opening, organizing, and printing
projects

Editing blocks and inserting program

Setting the window display and
components

arrangement, selecting the
language, and making settings for
process data

Downloading the program
and monitoring the
hardware

Calling the STEP 7 online help

QSIMATIE Manager - Gettng Started

File Edt Inzert PLC “iew Optonz Window Help

sl E T EE N =% 8= w2
'Ei?:jﬁelting Started - C:\Siemens\Step#\S57proj\Gettin_1

E--% Getting Started D

E-E] SIMATIC 300-Station
E| CPUI4M)
=-z3 57 Program(1]
@ Source Files
@ Blocks

[« Mo Fiter >

Press F1 to get Help L L i

The contents of the right-hand pane
show the objects and other folders
for the folder selected on the left

The contents of the left-hand pane
show the project structure

STEP 7 Getting Started 2-4
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The SIMATIC Manager

Calling the Help on STEP 7

F1

E? Help on STEP 7
&
Hide  Back Foward Home
corterts | ipdex | search | ) il
Overview of STEP 7
What is STEP 72

J[=] B3

Pt Glossay Obiecls

lewr? =
the Proctuct and Installng the ¢
atSTER 7,
[2] The STEP 7 Standard Packags
@ Extencied Uses of the STEP 7 Standal
= @ instaliation and Authorization
@ Working Outthe Autometion Concept
@ Stertup e Operetion
@ Setting Lip and Edting the Project
@ Configuring the Hardware.
@ Gonfiguring Gonnections and Date Exchal
Progtamming Blocks
@ Configuring Mes sages
Controling and Monitoring Veriales
Estebishing an Orline Connection nd Me
Dawrlasding and Uploarding
Debugging
@ Diagnostios
@ Frinting and Archiving
<

STEP 7 is the standard software package used for
canfiguring and programming SIMATIC
programmable lagic comtrollers. It is part of the
SIMATIC industry software. There are the following
versions of the STEP 7 Standard package:

« STEP 7 Micro/DOS and STEP 7 MicrofWin for
simpler stand-alone applications on the
SIMATIC 57-200.

« STEP7 for applications on SIMATIC S7-
300/57-400, SIMATIC M7-300/M7-400, and
SIMATIC C7 with a wider range of functions
o Can be extended as an option by the

saftware products in the SIMATIC Industry
Software (see also Extended Uses of the

_l;l STEP 7 Standard Package) <
> 4 | >|‘|

h?

Navigating in the Project Structure

ZJSIMATIC Manager - Gelling Started
PLC View Options MWindow Help

705- = (e |2 sl [= 25

a Started — C:\Giemens\Step7AS 7proit(

B Gettng Stared
I E SIMATIC 300-Station
=0 cruzan
&0 57 Progan(l)
Souce Fies

a

PressFl to get Help

STEP 7 Getting Started
A5E00069681-03

Option 1:

Place the cursor on any menu
command and press the F1 key. The
context-sensitive help for the selected
menu command will appear.

Option 2:

Use the menu to open the STEP 7
online help.

The contents page with various help
topics appears in the left-hand pane
and the selected topic is displayed in
the right-hand pane.

Navigate to the topic you want by
clicking the + sign in the Contents list.
At the same time, the contents of the
selected topic are displayed in the
right-hand pane.

Using Index and Find, you can enter
search strings and look for the specific
topics you require.

Option 3:

Click the question mark button in the
toolbar to turn your mouse into a help
cursor. The next time you click on a
specific object, the online help is
activated.

The project you have just created is
displayed with the selected S7 station
and CPU.

Click the + or — sign to open or close a
folder.

You can start other functions later on
by clicking the symbols displayed in
the right-hand pane.

2-5



The SIMATIC Manager

25 Getling Started - C:\SIEMENS\STEP7\S Zproi\Gettin_1

127 Getting Started - C:ASIEHENS\S I t8%nro/\Gettin_1

=) Getting Started
= SIMATIC 300 Station

R Ik
B 57 Program(1)

I Getting Started -- C:\SIEMEN 5\S [0#PW8Zoroj\Gettin_1

B~
N E

CPUZT41)

Click the S7 Program (1) folder. This
contains all the necessary program
components.

You will use the Symbols component
in Chapter 3 to give the addresses
symbolic hames.

The Source Files component is used to
store source file programs. These are
not dealt with in the Getting Started
manual.

Click the Blocks folder. This contains
the OB1 you have already created
and, later on, all the other blocks.

From here, you will start programming
in Ladder Logic, Statement List, or
Function Block Diagram in Chapters 4
and 5.

Click the SIMATIC 300 Station folder.
All the hardware-related project data
are stored here.

You will use the Hardware component
in Chapter 6 to specify the parameters
of your programmable controller.

If you require further SIMATIC software for your automation task; for example, the optional
packages PLCSIM (hardware simulation program) or S7 Graph (graphic programming
language), these are also integrated in STEP 7. Using the SIMATIC Manager, for example,
you can directly open the relevant objects such as an S7 Graph function block.

You can find more information under Help > Contents in the
topics "Working Out the Automation Concept" and "Basics of
Designing the Program Structure."

You can find more information on optional packages in the
SIMATIC catalog ST 70, "Components for Completely
Integrated Automation."

STEP 7 Getting Started
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3

Programming with Symbols

3.1 Absolute Addresses

Every input and output has an absolute address predefined by the hardware
configuration. This address is specified directly; that is, absolutely.

The absolute address can be replaced by any symbolic name you choose.

Digital input
module
Byte O

BitsOto 7

Digital input
module
Byte 1

Bits 0to 7

Absolute address: | 15

Input Byte 1 Bit 5

STEP 7 Getting Started
A5E00069681-03

Digital output
module
Byte 4
BitsOto 7

Digital output
module
Byte 5
Bits0to 7

3-1



Programming with Symbols

3.2 Symbolic Programming

3-2

In the symbol table, you assign a symbolic name and the data type to all the
absolute addresses which you will address later on in your program; for example,
for input | 0.1 the symbolic name Key 1. These names apply to all parts of the
program and are known as global variables.

Using symbolic programming, you can considerably improve the legibility of the

S7 program you have created.

Working with the Symbol Editor

a Started
MATIC 300 Station

[&& Symbol E ditor - [Getting Started\SIMATIC 300 Statio._.\Symbols]

Symbol Table Edi lnsen View Oplions Window Help ]
=l 5] klEle] Hle] R =19l el
Symbol | Address Data Type Comment |
1 [Cycle Execution 0B 1 0B 1
2

T oM

| Address |Data Type|

1 C!cleExecution ) 0B 1 OB 1
2

Symbol | Address |Data Type|
1 |Main Program oB 1 0B 1
2 |Green Light o] 4.0 BOOL
| Comment |

O

Symbol [ Address [Data Type|
1 |Main Program OB 1 0B 1
2 |Green Light ] 4.0 BOOL
3 |Red Light Q 4.1 BOOL

Navigate in the project window
"Getting Started" until you reach
S7 Program (1) and double-click to
open the Symbols component.

Your symbol table currently only
consists of the predefined organization
block OB1.

Click Cycle Execution and overwrite it
with "Main Program" for our example.

Enter "Green Light" and "Q 4.0" in
row 2. The data type is added
automatically.

Click in the comment column of row 1
or 2 to enter a comment on the
symbol. You complete your entries in a
row by pressing Enter, which then
adds a new row.

Enter "Red Light" and "Q 4.1" in row 3
and press Enter to complete the entry.

In this way, you can assign symbolic names to all
the absolute addresses of the inputs and outputs
which your program requires.

STEP 7 Getting Started
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Programming with Symbols

| E Save the entries or changes you have
U made in the symbol table and close the
window.

Because there are lots of names for the entire "Getting Started" project, you can
copy the symbol table to your "Getting Started" project in Section 4.1.

ESymbul Editor - [Getting Started\SIMATIC 300 Statio...\Symbols]
Symbol Table Edit [nsert Wiew Dptions ‘window Help = |ﬁ'|1|
S|E| 3| % |E=lE| ] [asmbs =19 E”
Symbol | Address [Data Type| Comment
1 | Automatic Mode Q 42 BOOL Retentive output
2 |Automatic_On | 05 BOOL For the mernory function (switch on)
3 |DE_Actual_Speed WY A4 INT Actual speed for diesel engine
4 |DE_Failure | 16 [BOOL Diesel engine failure H h bol
5 |DE Fan On Q 56 BOOL Comrnand for switching on diesel engine fan €re you can see the Sym O
6 |DE_Follow_On T 2 [TMER  |Follow-on time for diesel engine fan table for the S7 program in the
i |DE On Q 9.4 BOOL Command for switching on diesel engine "Getting Started" example for
8 |DE Preset_Speed_ReacheQ 5.5 [BOOL Display "Diesel engine preset speed reached'] :
9 |Diesel DB 2 FB 1 Datafor diesel engine Statement List.
10 |Engine FE. 1 FBE 1 Engine control Genera"y speaking, 0n|y one
11 [Engine_Data DE 10 FB 10 |Instance data block for FE10 .
12 |Engines FE 10 FB 10 Exarnple of multiple instances symbol table is created per
13 _|Fan FC 1 [FC 1 Fan control S7 program, regardless of
14 | Green_Light Q 40 BOOL Result of AMD guery which programming language
15 [Key_1 | 0.1 |BOOL For the AND query
16 |Key 2 | 02 BOOL  Forthe AND query you have selected.
| 17 |Key 3 | D3 BOOL _ Forthe OR query All printable characters (for
18 [Key 4 | 04 BOOL For the OR query f
19 |Main_Program OB 1 OB 1 |This block contains the user program example’ Spemal Fhara_CterS'
20 Manual_On | 05 BOOL For the memary functian (switch off) spaces) are permltted in the
21 |PE_Actual_Speed MY 2 INT Actual speed for petrol engine Symb0| table.
22 |PE_Failure | 1.2 BOOL Petrol engine failure
23 |PE_Fan_On Q 5.2 |BOOL Command for switching on petral engine fan
24 |PE_Follow On T 1 TIMER Follow-on time for petrol engine fan
25 |PE_On Q 50 BOOL Comrnand for switching on petrol engine
26 |PE_Preset_Speed_Reache 5.1 BOOL Display "Petral engine preset speed reached"
27 |Pstrol DB 1 FBE 1 Datafor petrol engine
28 |Red Light Q 4.1 |BOOL Result of OR query
29 |5 Data DB 3 DB 3 Shared data block
30 | Switch_Off DE | 15 BOOL Switch off diesel engine
I |Switch_Off PE | 1.1 |BOOL Switch off petrol engine
32 |Switch_On_DE | 1.4 |BOOL Switch on diesel engine
33 |Switch On PE | 1.0 BOOL Switch on petrol engine
o] '
Press F1 for help. NLUM s
The data type which was previously added automatically to the symbol table determines
the type of the signal to be processed for the CPU. STEP 7 uses, among others, the
following data types:
BOOL Data of this type are bit combinations. 1 bit (type BOOL) to 32 bits (DWORD).
BYTE
WORD
DWORD
CHAR Data of this type occupy exactly one character of the ASCII character set.
INT They are available for the processing of numerical values (for example, to calculate
DINT arithmetic expressions).
REAL
S5TIME Data of this type represent the different time and date values within STEP 7 (for
TIME example, to set the date or to enter the time value for a timer).
DATE
TIME_OF_DAY : : :
You can find more information under Help > -
Contents in the topics “Programming Blocks*
and "Defining Symbols". —
STEP 7 Getting Started 3-3
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4  Creating a Program in OB1

4.1 Opening the LAD/STL/FBD Program Window

Choosing Ladder Logic, Statement List, or Function Block Diagram

With STEP 7, you create S7 programs in the standard languages Ladder Logic
(LAD), Statement List (STL), or Function Block Diagram (FBD). In practice, and for
this chapter too, you must decide which language to use.

Ladder Logic (LAD)
Suitable for users from the electrical engineering industry, for example.

"Green Lig
"KEY_l rr "KEY_z r ht rr

r || | | T |
| [ | WS |

Statement List (STL)
Suitable for users from the world of computer technology, for example.

A rr KE .E;r_ 1 rr
A. rr KE .3?._2 rr
= "Green Light"

Function Block Diagram (FBD)
Suitable for users from the world of circuit engineering, for example.

& "Green Lig

"KE?_]. o ht™

e ?_2 v

The block OB1 will now be opened according to the language you chose
when you created it in the project Wizard. However, you can change the
default programming language again at any time.

STEP 7 Getting Started
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Copying the Symbol Table and Opening OB1

ﬁr If necessary, open your "Getting
C Started" project. To do this, click the
Open button in the toolbar, select the
"Getting Started" project you created,
and confirm with OK.

s'er projects | Librz

Depending on which programming
language you have decided to use,
open one of the following projects as

well:
e ZEn01_05_STEP7__LAD_1-9
« | e ZEn01_01_STEP7__STL_1-9
or
e —C= o 7En01_03_STEP7__FDB_1-9
DlS[Ee] - [-[5) &[5 2l & [ T =] %l
e = Here you can see all three sample

projects displayed.

Navigate in the ,ZEn01_XXX* until you
reach the Symbols component and
copy this by dragging and dropping it
to the S7 Program folder in your
project window "Getting Started."

ils 2 Then close the window ,ZEn01_XXX"

Drag and drop means that you click any object
with the mouse and move it whilst keeping the
mouse button depressed. When you release the
mouse button, the object is pasted at the selected
position.

Ee-llmgSIallzd - CASIEMENS\STPMearojiGettin_1 Double-click OB1 in the IIGEtting
- Started" project. The LAD/STL/FBD
] Egm” program window is opened.

In STEP 7, OB1 is processed cyclically by the CPU. The CPU reads line by line and
executes the program commands. When the CPU returns to the first program line, it has
completed exactly one cycle. The time required for this is known as the scan cycle time.

Depending on which programming language you have selected, continue reading in either
Section 4.2 for programming in Ladder Logic, Section 4.3 for Statement List, or Section 4.4
for Function Block Diagram.

I You can find more information under Help > Contents I
in the topics “Programming Blocks" and "Creating
I Blocks and Libraries.”

4-2 STEP 7 Getting Started
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The LAD/STL/FBD Program Window

All blocks are programmed in the LAD/STL/FBD program window. Here, you can
see the view for Ladder Logic.

Inserting a new
network

The most important program
elements for Ladder Logic and
Function Block Diagram

Toggling the Program
Elements catalog on and off

Moving the table split
(toggling the view of the
Changing the table on and off)
programming language
view

ELADISTLIFBD - [0B1 -- Getting Started\SIMATIC 300 Station\CPU314{1]]

3 File Edit Inset PLC Debug Wiew Options ‘Window Help & x|

iR &l (e o]c] cldl [ 2] ] e AolEs == el /

Address |Decl. Hame Type Initial ValiCamment ﬂ £ New Network
0.0tenp ! 1 I 1 0-3 = 1 (Coming/event), Bits 4-7 = U"EE!..E:&:Q:?_
L.0[tenp The variable declaration table contains pid restart scef 1 of 08 1), 3 (zce e
B/l s the parameters and local variables for ~ fioraty of 1 £ lowest) P
3.0]tenp the block ganization Ylock 1, o8y f o i
4.0 temp ved for syftem . < Rl
5.0|temp ved fuxy%stem Er élg]

6.0l temn TOETFRE TETTIT T T Tt time off previous OBl secan (milli=<l| = . I sk
TR o s o
ﬂ ..... G AP
OBl : Title: < -[SAVE]
i . £ NEG
Corment: Title and comment field for |/ [ . 7 ros
the block or network -0 Compars
......... . -85 Convert
Metwork 1i: Title: [ Caunters
[ Data Block Function
Conment : (-5 Logic Contral / Jump
B-ET Integer Math
{28 Floating-Point Math

Program Elements catalog,
here for Ladder Logic

Program input line (also network
and current path) ez

FC Blocks

S5FB Blocks
SFCBlocks

@) Mulliple Instances
A Libiaries

Information on the selected
program element | B Logic =

Press F1 for help, [bo (bt NS
Help on the selected /
program element

IL‘\
I~ | 1

STEP 7 Getting Started
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4.2 Programming OB1in Ladder Logic
In the following section, you will program a series circuit, a parallel circuit, and the
set / reset memory function in Ladder Logic (LAD).
Programming a Series Circuit in Ladder Logic

If necessary, set LAD as the

programming language in the View
menu.

Ctrl+1
Chil+2
Crl+3

031 Click in the title area of OB1 and enter

Comment : "Cyclically processed main program,”
for example.
L € ‘ ‘ Select the current path for your first
e element.

| Click the button in the toolbar and
insert a normally open contact.

In the same way, insert a second
normally open contact.

_() Insert a coil at the right-hand end of
the current path.

}_‘ ”.7 ? The addresses of the normally open
‘ a — contacts and the coil are still missing in
the series circuit.

Check whether symbolic
representation is activated.

Dizplay with ¥ v Sumbolic Representation Chi+Q
- Symbollnformation Ctil+Shift+2
Symbaol Selection Clrl+7
v Comment Crl+S hift+k.

Address [dentification

4-4 STEP 7 Getting Started
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> X .2 Click the ??.? sign and enter the

o {} - . . .
symbolic name "Key_1" (in quotation
marks).

Confirm with Enter.

. 7.7 .2 Enter the symbolic name "Key_2" for
‘ " "~ the second normally open contact.
». .2 77 Enter the name "Green_Light" for the
‘ h coil.
"Green Lig You have now programmed a
Rey 1T "Rey 27 he” complete series circuit.

‘ | | {

Save the block if there are no more
symbols shown in red.

STEP 7 Getting Started 4-5
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Programming a Parallel Circuit in Ladder Logic

o o o o o S
‘llet.wurk ib) Title:
e

Comment :

?2.2

2.2
f -
2.2
"Red Light
Key 3 "
|| |r J
[ Y
Key_ 4
K

4-6

Select Network 1.

Insert a new network.

Select the current path again.

Insert a normally open contact and a
coil.

Select the vertical line of the current
path.

Insert a parallel branch.

Add another normally open contact in
the parallel branch.

Close the branch (if necessary, select
the lower arrow).

The addresses are still missing in the
parallel circuit.

To assign symbolic addresses,
proceed in the same way as for the
series circuit.

Overwrite the upper normally open
contact with "Key_3," the lower contact
with "Key_4," and the coil with
"Red_Light."

Save the block.

STEP 7 Getting Started
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a

Programming a Memory Function in Ladder Logic

HH:-|
[ .

777
SR
s a
iR

"Aautomstic
_Mode™

"Automatic

_on” SR

f——o= Q

"Manual On
"

—R

1=

Select Network 2 and insert another
network.

Select the current path again.

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

Insert a normally open contact in front
of each of the inputs S and R.

Enter the following symbolic names for
the SR element:

Upper contact "Automatic_On"

Lower contact "Manual_On"

SR element "Automatic_Mode"

Save the block and close the window.

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

"Green Lig
"Key 2" he"
| |
1

Example:
Symbolic addressing in LAD

characters.

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Width of
address field" in the "LAD/FBD" tab. Here you can set the line break between 10 and 24

Example:
Absolute addressing in LAD

STEP 7 Getting Started

A5E00069681-03

You can find more information under Help > —
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing Ladder
Instructions."
4-7
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4.3 Programming OB1 in Statement List

In the following section, you will program an AND instruction, an OR instruction,
and the memory instruction set/reset in Statement List (STL).

Programming an AND Instruction in Statement List

AT Chrl+1
CsiL) Cule2
FED Ctrl+3
Dizplay with ¥ v Sumbolic Representation Chi+Q
Symbol Information Ctrl+Shift+C
Symbaol Selection Clrl+7
v Comment Crl+S hift+k.

Address [dentification

OE1l :< Title :’

Cortnent :

e vrozk 1ERCiaEE

Corrnent :

»

4-8

If necessary, set STL as the
programming language in the View
menu.

Check whether symbolic
representation is activated.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the area for your first statement.

Type an A (AND) in the first program
line, a space, and then the symbolic
name "Key_1" (in quotation marks).

Complete the line with Enter. The
cursor jumps to the next line.

STEP 7 Getting Started
A5E00069681-03
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I o

rr KE .E;r_ 1 rr
rr KE .3?._2 rr
"Green Light"

In the same way, complete the AND
instruction as shown.

You have now programmed a
complete AND instruction. Save the
block if there are no more symbols
shown in red.

Programming an OR Instruction in Statement List

.
le twork D i

STEP 7 Getting Started
A5E00069681-03

o o

rr KE .5?._3 rr

r KE ?_3 r
r KE ET_"I'I r
"Red Light"

Select Network 1.

Insert a new network and select the
input area again.

Enter an O (OR) and the symbolic
name "Key_3" (in the same way as for
the AND instruction).

Complete the OR instruction and save
it.

4-9
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Programming a Memory Instruction in Statement List

Hic Select Network 2 and insert another

Pl network.
A "Automatic On' In the first line, type the instruction A
with the symbolic name
"Automatic_On."
"Automwatic On" Complete the memory instruction and
rautomatic Mode" save it. Close the block.

"Manual On"

E "Automatic Mode"

oo

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.
A "KE ¥ 1 " Example:
Key 2 Symbolic addressing in STL
= "Green Light"
A I 0.1 Example:
2 1 0.2 Absolute addressing in STL
= 4.0
You can find more information under Help > -
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing STL
Statements."
4-10 STEP 7 Getting Started
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4.4 Programming OB1in Function Block Diagram

In the following section, you will program an AND function, an OR function, and a
memory function in Function Block Diagram (FBD).

Programming an AND Function in Function Block Diagram

L&D Crl+1

Crl+2
Chrl+3

Comment :

uecvork LECtaEE

Comment :

_—

g5 g

P2, 7 — P2 3

22, 72— —

Display with ¥ v Sumbolic Representation Cl+Q
- Symbolnformation Clrl+Shift+0
Sembaol Selection Chil+7
v Comment Clrl+Shift+k,

Address |dentification

STEP 7 Getting Started
A5E00069681-03

If necessary, set FBD as the
programming language in the View
menu.

Click in the title area of OB1 and enter
"Cyclically processed main program,"
for example.

Select the input area for the AND
function (below the comment field).

Insert an AND box (&) and an
assignment (=).

The addresses of the elements are still
missing in the AND function.

Check whether symbolic
representation is activated.

4-11
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i Click on the ??.? sign and enter the
7.2 symbolic name "Key_1" (in quotation
22 2] - = marks). Confirm with Enter.
z Enter the symbolic name "Key_2" for
?2. 7 — .2 the second input.
z Enter the name "Green_Light" for the
22,7 — 2?2 assignment.
22,7 — — )
i "Green Lig You have now programmed a
"Key 1" — ht" complete AND function.
"KE?_Z L I— —
. If there are no more symbols shown in
red, you can save the block.
4-12 STEP 7 Getting Started
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Programming an OR Function in Function Block Diagram

HH:-|
[ .

Comment :

0|

==1
27, 7 — ?2.?
7?7, 7 — — )
==1 "Red Light
"KE? L g— "
"Key_f-l" ]

STEP 7 Getting Started
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1=

Insert a new network.

Select the input area again for the OR
function.

Insert an OR box (=1) and an
assignment (=).

The addresses are still missing in the

OR function. Proceed in the same way
as for the AND function.

Enter "Key_3" for the upper input,
"Key_4" for the lower input, and
"Red_Light" for the assignment.

Save the block.

4-13
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Programming a Memory Function in Function Block Diagram

Hr Select Network 2 and insert another
. network. Select the input area again
(below the comment field).

Navigate in the Program Elements
catalog under Bit Logic until you
reach the SR element. Double-click to
insert the element.

" Automatic Mode" Enter the following symbolic names for
the SR element:
"Automaticon” = SR Set "Automatic_On"
s Reset "Manual_On"
Memory bit "Automatic_Mode"
"Manual on" —E o

El Save the block and close the window.

a

If you want to see the difference between absolute and symbolic addressing, deactivate the
menu command View > Display > Symbolic Representation.

& "Green_Light"

"Key 1" —| Example:

= Symbolic addressing in FBD
'Key 2 = —

&
Example:
— 4.0 I

0.1 Absolute addressing in FBD
10.2 — —

You can change the line break for symbolic addressing in the LAD/STL/FBD program
window by using the menu command Options > Customize and then selecting "Address

Frleld LU A e LD You can find more information under Help > d24

Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing FBD
Statements."

4-14 STEP 7 Getting Started
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5 Creating a Program with Function Blocks

and Data Blocks

5.1 Creating and Opening Function Blocks (FB)

The function block (FB) is below the organization block in the program hierarchy. It
contains a part of the program which can be called many times in OB1. All the
formal parameters and static data of the function block are saved in a separate
data block (DB), which is assigned to the function block.

You will program the function block (FB1, symbolic name "Engine"; see symbol
table, page 3-3) in the LAD/STL/FBD program window, which you are now familiar
with. To do this, you should use the same programming language as in Chapter 4

(programming OB1).

= SIMATIC 300 Station
- cruste
B SEA

Function Black

STEP 7 Getting Started
ABE00069681-03

You should have already copied the
symbol table into your project "Getting
Started." If not, read how to do this on
page 4-2, copying the symbol table,
and then return to this section.

If necessary, open the "Getting
Started" project.

Navigate to the Blocks folder and
open it.

Click in the right-hand half of the
window with the right mouse button.

The pop-up menu for the right mouse
button contains the most important
commands from the menu bar. Insert a
function block as a new object.
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a

Eigenschaften - Funktionsbaustein [x]
General - Part 1 | General- Pan 2| Calls | Atrbutes |
Name: [V Muliple Instance Capabi
Symbalic Name: Engine
Syrbal Comment:
Created in Langua
Project Path: I
Storags location
of project [C\Siemens\Step73 7proj\Gettin 1
Code Inteiface
Date created: 12.04.2000 13.02:18
Last modified: 12.04.2000 13.02:18 12.04.2000 13:0218
Comment ’ =
< > Cancel Help
5 Getting Started - CASIEMENSAS TERZAS 7proj\Gettin_1
=& Getling Started
=] SIMATIC 300-Station ‘ D
=-[@ cruziam 081
1D $7-Programmil)

B Quelk

len
Basterne;

Double-click FB1 to open the
LAD/STL/FBD program window.

In the "Properties — Function Block"
dialog box, select the language in
which you want to create the block,
activate the check box "Multiple
instance FB," and confirm the
remaining settings with OK.

The function block FB1 has been
inserted in the Blocks folder.

Depending on which programming language you have selected, continue reading in either
Section 5.2 for Ladder Logic, Section 5.3 for Statement List, or Section 5.4 for Function
Block Diagram.

5-2

| You can find more information under Help >

Contents in the topics "Programming Blocks" and
"Creating Blocks and Libraries."

STEP 7 Getting Started
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5.2 Programming FB1 in Ladder Logic
We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter a series circuit, a parallel circuit, and a
memory function with STEP 7.

1. Filling out the Variable Declaration Table

== Your LAD/STL/FBD program window is
open and the option View > LAD
(programming language) is activated.

1) i) @] 11110 w2l

Note that FB1 is now in the header,
. because you double-clicked FB1 to
T open the program window.

Enter the following declarations in the variable declaration table.

To do this, click a cell and use the corresponding name and the comment from the
illustration below.

You can select the type with the pop-up menu command Elementary Types using
the right mouse button. When you press Enter, the cursor jumps to the next
column, or a new row is inserted.

Address [Decl. Hame Type Initial Value |Comment
0.0|in Switch_on EOOL FALSE Switch on engine
0.1|in Switch OFf BOOL FALSE Switch off engine
0.2|in Failure EOOL FALSE Engine failure, causes the engine to switch off
Z.0|in Actual Speed INT 0 Actual engine speed
4.0|out Engine_On EOOL FALSE Engine is switched on
4.1|out Preset Speed Reached |BOOL FALSE Preset speed reached
in_out
6.0|stat Preset Speed INT 1500 Requested engine spesd
temp

Only letters, numbers, and the underscore are permitted
characters for the names of the block parameters in the
variable declaration table.

STEP 7 Getting Started 5-3
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2. Programming an Engine to Switch On and Off

‘ 77?7

s s = Insert a normally open contact, a
| I 4 3 o— normally closed contact, and an SR
—r element in series in Network 1 using
the corresponding buttons in the
toolbar or the Program Elements
catalog.

2.7
PP
SR

Then select the current path
immediately before the input R.

P77 Insert another normally open contact.
e SO ] Selectthe current path immediately
2.2 before this contact.
Ok

|_). | _M_l _.I.l Insert a normally closed contact
parallel to the normally open contact.
Check whether symbolic
representation is activated.

Display with F v Sumbolic Representation  Ctil+Q)
~ Symbol nformation Clrl+5 hift+C1
Symbal Selection Ctrl+7
v Comment Clrl+5 hift+£

Address |dentification

Select the question marks and enter the corresponding names from the variable
declaration table (the # sign is assigned automatically).

Enter the symbolic name "Automatic_Mode" for the normally closed contact in the
series circuit.

Then save your program.

"Automatic H#Engine Cn
#Switch On Mode” SR
| | /1 3 2
#owiteh Of
f
| | R
#iFailure
|/ Local block variables are indicated with a # sign and are only valid in the
1] block.
Global variables appear in quotation marks. These are defined in the

symbol table and are valid for the entire program.

The signal state "Automatic_Mode" is defined in OB1 (Network 3; see page
4-7) by another SR element and now queried in FB1.

5-4 STEP 7 Getting Started
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3. Programming Speed Monitorin

CMP | >=

ad

g

Insert a new network and select the
current path.

Then navigate in the Program
Elements catalog until you reach the
Compare function and insert a
CMP>=,

Also insert a coil in the current path.

Select the question marks again and label the coil and the comparator with the
names from the variable declaration table.

Then save your program.

[o]

#Preset Sp
eed Reache
CMP == d
oy |
L |
#hotual 3p
eed —{INl
#Preset_Sp
eed —1nZ

When is the engine switched on and off?

"0," the engine is switched off. This function is ach
a "zero-active" signal and has the signal "1" in the

When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

ieved again by negating #Fault (#Fault is
normal state and "0" if a fault occurs).

Contents in the t

You can find more information under Help > s

"Creating Logic Blocks," and "Editing the Variable
Declaration Table" or in "Editing LAD Instructions."

opics "Programming Blocks,"

STEP 7 Getting Started
A5E00069681-03
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5.3 Programming FB1 in Statement List

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND instruction, an OR instruction, and
the set/reset memory instructions with STEP 7.

=

. Filling out the Variable Declaration Table

% Your LAD/STL/FBD program window is
open and the option View > STL
(programming language) is activated.

[rrme.

Note that FB1 is now in the header,
because you double-clicked FB1 to
S open the program window.

Ok, e st LTS I ER

Enter the following declarations in the variable declaration table.

To do this, click a cell and use the corresponding name and the comment from the
illustration below.

You can select the type with the pop-up menu command Elementary Types using
the right mouse button. When you press Enter, the cursor jumps to the next
column, or a new row is inserted.

BAddress [Decl. Hame Type Initial Value |Comment
0.0|in Switch_on BOCL FALSE Switch on engine
0.1|in switch Off BOCL FALSE Switch off engine
0.2|in Failure BOCL FALSE Engine failure, causes the engine to switch off
2.0|in Actual Speed INT 0 Actual engine speed
4.0|out Engine_on BOCL FALSE Engine is switched on
4.1|out Preset_Speed Reached |BOCL FALSE Preset speed reached
in_out
6.0[stat Preset_Speed INT 1500 Reguested engine speed
temp

Only letters, numbers, and the underscore are permitted
characters for the names of the block parameters in the
variable declaration table.

5-6 STEP 7 Getting Started
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2. Programming an Engine to Switch On and Off

Display with ¥ v Symbolic

Check whether symbolic
representation is activated.

Reprezentation  Ctrl+0

Symbal Infarmation Chrl+Shift+3
Symbal Selection Clrl+7
v Comment Chrl+5hift+£,
Address |dentification
A #Switch_On Enter the corresponding instructions in
AN "Automatic Mode' Network 1.
3 #Engine On
o #owitch Off : o : :
oN #Failure Local block variables are indicated with a # sign and
R #Engine On are only valid in the block.

Global variables appear in quotation marks. These
are defined in the symbol table and are valid for the
entire program.

The signal state "Automatic_Mode" is defined in
OB1 (Network 3; see page 4-10) by another SR
element and now queried in FB1.

3. Programming Speed Monitoring

L #ictual Speed Insert a new network and enter the
L #Preset_Speed corresponding instructions. Then save
=1

E = #Preset_Speed Reached

your program.

When is the engine switched on and off?

When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration Table" or in "Editing STL Statements."

STEP 7 Getting Started
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5.4 Programming FB1 in Function Block Diagram

We will now show you how to program a function block which can, for example,
control and monitor a petrol or diesel engine using two different data blocks.

All "engine-specific" signals are passed on as block parameters from the
organization block to the function block and must therefore be listed in the variable
declaration table as input and output parameters (declaration "in" and "out").

You should already know how to enter an AND function, an OR function, and a
memory function with STEP 7.

1. Filling out the Variable Declaration Table

a1 e ) siniole L) % Your LAD/STL/FBD program window is
—— — open and the option View > FBD
(programming language) is activated.

Ll

Note that FB1 is now in the header,
because you double-clicked FB1 to
S open the program window.

Enter the following declarations in the variable declaration table.

To do this, click a cell and use the corresponding name and the comment from the
illustration below.

You can select the type with the pop-up menu command Elementary Types using
the right mouse button. When you press Enter, the cursor jumps to the next
column, or a new row is inserted.

BAddress [Decl. Hame Type Initial Value |Comment
0.0|in Switch_on BOCL FALSE Switch on engine
0.1|in switch Off BOCL FALSE Switch off engine
0.2|in Failure BOCL FALSE Engine failure, causes the engine to switch off
2.0|in Actual Speed INT 0 Actual engine speed
4.0|out Engine_on BOCL FALSE Engine is switched on
4.1|out Preset_Speed Reached |BOCL FALSE Preset speed reached
in_out
6.0[stat Preset_Speed INT 1500 Reguested engine speed
temp

Only letters, numbers, and the underscore are
permitted characters for the names of the block
parameters in the variable declaration table.

5-8 STEP 7 Getting Started
A5E00069681-03



Creating a Program with Function Blocks and Data Blocks

2. Programming an Engine to Switch On and Off

&
R, P—

B

R, P—

22, 2 — —@

Insert an SR function in Network 1
using the Program Elements catalog

P
R (Bit Logic folder).

Add an AND box at input S (Set), and
an OR box at input R (Reset).

Display with ¥ v Sumbolic Representation Cl+Q
Symbol Information
Sembaol Selection

v Comment

Q e
Check whether symbolic
representation is activated.
Chrl+5 hift+0)
Crl+7
Chrl+5 hift+.

Address |dentification

Click the ??.? sign and enter the corresponding names from the declaration table
(the # sign is assigned automatically).

Make sure that one input of the AND function is addressed with the symbolic
name "Automatic_Mode."

Negate the inputs "Automatic_Mode" and #Fault with the corresponding button

from the toolbar.

Then save your program.

#3witch On—

"Automatic
_Mode" =

#awitch Of
£ —_

HFailure =

==

#Engine On
SR
13

STEP 7 Getting Started
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Local block variables are indicated with a # sign and are only
valid in the block.

Global variables appear in guotation marks. These are
defined in the symbol table and are valid for the entire
program.

The signal state "Automatic_Mode" is defined in OB1
(Network 3; see page 4-14) by another SR element and now
queried in FB1.
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3. Programming Speed Monitoring

4 &

oy

El

Insert a new network and select the

ESCompare input area.

Then navigate in the Program
Elements catalog under you reach the
Compare function, and insert a
CMP>=|,

Append an output assignment to the comparator and address the inputs with the
names from the variable declaration table.

Then save your program.

H#Actual Sp
eed

#Preset 3p

o] ™

CMP ==I
#Preset Sp
Hi eed Reache
d
1Nz

When is the engine switched on and off?

When the variable #Switch_On has signal state "1" and the variable "Automatic_Mode" has
signal state "0," the engine is switched on. This function is not enabled until
"Automatic_Mode" is negated (normally closed contact).

When the variable #Switch_Off has signal state "1" or the variable #Fault has signal state
"0," the engine is switched off. This function is achieved again by negating #Fault (#Fault is
a "zero-active" signal and has the signal "1" in the normal state and "0" if a fault occurs).

How does the comparator monitor the engine speed?

The comparator compares the variables #Actual_Speed and #Setpoint_Speed and assigns
the result of the variables to #Setpoint_Speed_Reached (signal state "1").

5-10

You can find more information under Help >
Contents in the topics "Programming Blocks,"
"Creating Logic Blocks," and "Editing the Variable
Declaration Table" or in "Editing FBD Instructions."

STEP 7 Getting Started
A5E00069681-03



Creating a Program with Function Blocks and Data Blocks

5.5 Generating Instance Data Blocks and Changing Actual
Values

You have just programmed the function block FB1 ("Engine") and defined, among
other things, the engine-specific parameters in the variable declaration table.

In order for you to be able to program the call for the function block in OB1 later
on, you must generate the corresponding data block. An instance data block (DB)
is always assigned to a function block.

The function block is to control and monitor a petrol or diesel engine. The different
setpoint speeds of the engines are stored in two separate data blocks, in which
the actual value (#Setpoint_Speed) is changed.

By centrally programming the function block only once, you can cut down on the

amount of programming involved.

257 Getting Started -- C:ASIEMENS\S TEP7AS 7projGettin_1

Getling Started
-l SIMATIC 300 Station
= [@ crustam
=-EA 57 Program(1]
* (@] Source Files
*424 Blocks

E Inzert Mew Object ; 4 .
coo < Drata Block )

Properties - Data Block

General -Pait 1 | General - Part 2| Calls | atibutes |

Nare ]
Symbolic Name: Pewol
SmtolComment ]
Crereitlamess 08
Project Path Geting StartediSIMATIC
300 Station\CPU31 (1557 Frogramm{1 \Bausteine!\DET
Stcrage location
of project CASiemens\Sten\ST o Betin |
Code Intertace
Dits crasted 12/04/2000 020233
Last modified 12/04/2000 (20545 12/04/2000 015336
Conment ’ =
(T Cancel Help
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The "Getting Started" project is open in
the SIMATIC Manager.

Navigate to the Blocks folder and click
in the right half of the window with the
right mouse button.

Insert a data block using the pop-up
menu with the right mouse button.

Accept all the settings displayed in the
"Properties” dialog box with OK.

The data block DB1 is added to the
"Getting Started" project.

Double-click to open DB1.

5-11
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a

Hew Data Block E
Black: DBl
Pragramming taal: IDB Editar 'l

" Data block

" Data block referencing a user-defined data type

+ iita biock referencing a function block:

BReference:

1 Cancel Help |

Data Wiew
Declaration YWiew

Rdee

Razere oot

HHEEEE

Activate the option Data block
referencing a function block in the
"New Data Block" dialog box.

Confirm the assignment "FB1, Engine*“
with OK.

The LAD/STL/FBD program window
opens with the data from the variable
declaration table for FB1.

DB1 is now to contain the data specific
to a petrol engine. You still have to
enter these data. First set the Data
View.

Next enter the value "1500" for the
petrol engine in the Actual Value
column (in the row "Setpoint_Speed).
You have now defined the maximum
speed for this engine.

Save DB1 and close the program
window.

In the same way as for DB1, generate
another data block, DB2, for FB1.

Now enter the actual value "1200" for
the diesel engine.

By changing the actual values, you have finished your preparations for controlling two
engines with just one function block. To control more engines, all you have to do is generate
additional data blocks.

The next thing you have to do is program the call for the function block in OB1. To do this,
continue reading in Section 5.6 for Ladder Logic, Section 5.7 for Statement List, or
Section 5.8 for Function Block Diagram, depending on the programming language you are

using.
You can find more information under Help > Contents
in the topics "Programming Blocks" and "Creating =
Data Blocks."
5-12 STEP 7 Getting Started
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5.6 Programming a Block Call in Ladder Logic

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

DB1
Petrol Engine
Data

FB1
OB1
"Engine" M j I-
Call
| >t
Diesel Engine
Data

Tt

' Gotting Started — C:ASIEMENSAS [ERZAS 7proi\Gettin_1

= — = — The SIMATIC Manager is open with
i T your "Getting Started" project.

=0 57 Prox
(@ So

Navigate to the Blocks folder and
open OB1.

Insert Network 4 in the LAD/STL/FBD
program window. Then navigate in the
Program Elements catalog until you
reach FB1 and insert this block.

Insert a normally open contact in front
) of each of the following: Switch_On,
: I Switch_Off, and Fault.

} teh_Off

Click the ??? sign above "Engine" and
i then, keeping the cursor in the same

e position, click in the input frame with
the right mouse button.

Select Insert Symbol in the pop-up

menu using the right mouse button. A
Qﬁ'ti"mmo i+ pull-down list will appear. The first time
you do this, the procedure may take
some time.

STEP 7 Getting Started 5-13
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5-14

Click the data block Petrol. This block

=T

PE_Failure
PE_Fan_On

b ain_Program ae

= I
_Actual_opeed b

I
o

PE_Follow_On T

0.2

0.
1

1.2
l
1

-

is then entered automatically in the
input frame in quotation marks.

Click the question marks and address all the other parameters of the function
block using the corresponding symbolic names in the pull-down list.

"Petrol”

"Switch On_PE"
I

"switeh off PE"
||
1

"PE_Failure"
| 1

"PE_Actual Speed”

EN

Fwitch On

Zwiteh Off

Failure

0

Actual Speed

"Engine"

ENO

Engine On|—-"pgE on"

Preset_Speed Reac| "PE Preset Speed R

hed

Feached™

The engine-specific input
and output variables
(declaration "in" and "out")
are displayed in the FB
"Engine."

A signal "PE_xxx" is
assigned to each of the
variables for the petrol
engine.

STEP 7 Getting Started
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Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down

list.
"Diesel"
"Engine™
EN ENO
"Zwitch On DE” Engine On—"DpE On"
| | Switch On
Preset_Speed Reac "DE_Preset_Zpeed R
"witch Off DE" hed Feached”
| | Switch off
"DE Failure"
| Failure A signal "DE_xxx" is

assigned to each of the
variables for the diesel
engine.

"DE_Actual Speed"—Actusal Speed

El Save your program and close the
E block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example,
FB1 has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

You can find more information under Help > Contents
in the topics "Calling Reference Helps," "Language rm—
Description: LAD," and "Program Control Instructions."

STEP 7 Getting Started 5-15
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5.7 Programming a Block Call in Statement List

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this

way, you can control both engines.

OB1

5% Gelting Started - C:\SIEMENS\STERZAS 7proi\Gettin_1

P s | o = =
=@ cruztem 081 FB1 Bl D82
[SRE) S?P ]
8 ies
HH
|
—
"Engine™ , "Petrol”
Switch On =
Switch Off =
Failure =

Actual Speed
Engine ©n

Preset Speed Reached

< Inzert Symbol > Ctrl+d

5-16

DB1
Petrol Engine
Data

.-Englne M i F
Call

DB2

Diesel Engine
Data

It

The SIMATIC Manager is open with
your "Getting Started" project.

Navigate to the Blocks folder and
open OB1.

Insert Network 4 in the LAD/STL/FBD
program window.

Type CALL "Engine", "Petrol" in the
code section and then press Enter.

All the parameters of the function block
"Petrol" are displayed.

Position the cursor after the equals
sign of Switch_On and press the right
mouse button.

Select Insert Symbol in the pop-up
menu using the right mouse button. A
pull-down list will appear. The first time
you do this, the procedure may take
some time.

STEP 7 Getting Started
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EE_EH \ Soued t E" Click the name Switch_On_PE. This
el is taken from the pull-down list and
S witch_0ff_DE |1 added automatically in quotation
Switch_0OIf_PE I marks
T R '
<Switch_Dn_F'E D 1
= DB v
CALL "Engine” , "Petrol” Assign all the required addresses to
Switch On 1="Switeh On PE" . R
Switch OFf i="Suitch Off PE" the variables of the function block
Failure :="PE Failure" i - i
Actual Speed ="PE:Actual_SpEEd" USIng the pu” down IISt
Engine On :="PE_On'"

Preset_Speed Reached:="PE_Freset_Speed Reached” A Signa| "PE xxx"is assigned
to each of the variables for
the petrol engine.

o gine® s "hiesml . Program the call for the function block
witeh On :=MBwitch On DE " . " N

Switeh Off :="Switch OFf_DE" Engine" (FB1) with the data block
Fail :="DE Fail " npEy; n H

Acbual Spesd —"DE Actual Specd” Diesel" (DB2) in a new network.

Engine_on "DE_on" Proceed in the same way as for the
Preset_3Speed Reached:="DE_Preset Spesd Reached"

other call.

El Save your program and close the
E block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File >
Archive or File > Print.

You can find more information under Help > Contents o
in the topics "Calling Reference Helps," "Language
Description: STL," and "Program Control Instructions."
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5.8 Programming a Block Call in Function Block Diagram

All the work you have done programming a function block is of no use unless you
call this block in OB1. A data block is used for each function block call, and in this
way, you can control both engines.

DB1
Petrol Engine
Data

FB1
OB1
"Engine” M i F
Call
| =1t

Diesel Engine
Data

Tt

The SIMATIC Manager is open with

el Cir your "Getting Started" project.
S Navigate to the Blocks folder and
open OB1.

Insert Network 4 in the LAD/STL/FBD
program window. The navigate in the
Program Elements catalog until you
reach FB1 and insert this block.

272 All the engine-specific input and output
\Uengine/ variables are displayed.

Click the ??? sign above "Engine" and
Engine on| then, keeping the cursor in the same

. —|switen off T position, click in the input frame with
Freset_speed _Reac the right mouse button.

.. —Failure hed ...

..—EN

.. =—{Switch On

.. —lactual Speed ENO|—

Select Insert Symbol in the pop-up
6 menu using the right mouse button. A
Insert Symbol Cliked pull-down list will appear. The first time
you do this, the procedure may take
some time.

5-18 STEP 7 Getting Started
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| Click the data block Petrol. It is taken

Koy 4 T nia from the pull-down list and entered
b ain_Program 0B automatically in the input frame in
= 0. guotation marks.
el D% 1
FE_Failure [ J
FE_Fan_On B 5.
FE_Follow On T 1=

Address all the other parameters of the function block using the corresponding
symbolic names in the pull-down list.

"Petrol™
"Engine™
. —{EN
"Switch On PE" —{Switch On
Engine One="pgE on"
"Switch Off PE" —{Switch Off
Freset_Speed Reac| "PE Preset_Speed R
"PE Failure" — Failure hed l=eached"”
"PE Actual Speed” —{2ctual Speed ENO f—
A signal "PE_xxx" is assigned
to each of the variables for the
petrol engine.
STEP 7 Getting Started 5-19
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Program the call for the function block "Engine" (FB1) with the data block "Diesel"
(DB2) in a new network and use the corresponding addresses from the pull-down

list.
A signal "DE_xxx" is assigned to
each of the variables for the
diesel engine.
"Diezel"
"Engine"
. —|EN
"Switch On DE" —Switch On
Engine Onp="pg on"
"Switch off DE" ——Switch Off
Preset Speed Reac| "DE Preset speed R
"DE Failure" — Failure hed —eached”
"DE Actual ZIpeed” —{Actual Speed ENC

E Save your program and close the
E _| block.

When you create program structures with organization blocks, function blocks, and data
blocks, you must program the call for subordinate blocks (such as FB1) in the block above
them in the hierarchy (for example, OB1). The procedure is always the same.

You can also give the various blocks symbolic names in the symbol table (for example, FB1
has the name "Engine" and DB1 the name "Petrol").

You can archive or print out the programmed blocks at any time. The corresponding
functions can be found in the SIMATIC Manager under the menu commands File > Archive
or File > Print.

You can find more information under Help > Contents
in the topics "Calling Reference Helps," "Language r—
Description: FBD," and "Program Control Instructions."
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6 Configuring the Central Rack

6.1 Configuring Hardware

You can configure the hardware once you have created a project with a SIMATIC
station. The project structure which was created with the STEP 7 Wizard in
Section 2.1 meets all the requirements for this.

The hardware is configured with STEP 7. These configuration data are transferred
to the programmable controller later on "downloading” (see Chapter 7).

I Getting Started -- C:\SIEMENSY%c /A5 Mygoj\Gettin_1

The starting point is the open SIMATIC
‘ ﬂnﬂ cpm Manager together with the "Getting
Started" project.

Open the SIMATIC 300 Station folder
and double-click the Hardware
symbol.

Files

T Blocks

The "HW Config“ window opens. The CPU you selected on creating the project is
displayed. For the "Getting Started" project, this is CPU 314.

[ HW Config - [SIMATIC 300 Station (Configuration) -- Getting Started]

Bl Staton Edit Inset PLC Yiew Oplions Window Help EE

Dleslz-{2] S =

:I Profile [Standard ]
‘I s B% FROFIEUS DF
B SIMATIC 300
SIMATIC 400
SIMATIC PC Based Control 3004400
-8, SIMATIC PC Station

Rack with individual slots

4 | LI_I Hardware
@ Catalog
ot Module | Drder Wuraber MPI Addiess | 14dd...| O... | Comment |
[H cPuzTem IE_£S7 3141AEO40ABD B

\lmmhm‘y\_\|—tm

Configuration table with
the MPI and I/0
addresses

Short information on the
selected element

OFIBUS-DP slaves for SIMATIC 57, M7,
and C7 (distrbuted rack]

Help on the selected element

Fress F1 for help.

=

[ "
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[ mmn

=-

[Fmmsn

= SimaTic 300

=] Ps-300

SIMATIC 300

- =13 5M-300

-

First you require a power supply
module. Navigate in the catalog until
you reach the PS307 2A and drag and
drop this onto slot 1.

Navigate until you find the input
module (DI, Digital Input) SM321
DI32xDC24V and insert this in slot 4.
Slot 3 remains empty.

In the same way, insert the output
module SM322 DO32xDC24V/0.5A in
slot 5.

In order to change the parameters (for example, address) of a module within a
project, double-click the module. However, you should only change the

parameters if you are sure you know what effects the changes will have on your
programmable controller.

No changes are necessary for the "Getting Started" project.

Order Mumber

MPI Address

| &dd... | O... | Comment

EEST 307-1BAD0-0A40

Module
PS307 24
CPLI314(1]

EES7 314-1AE04-04B0

2

(S ENTRITSTE £
=

Di32sDC24Y
D320 C24W /0. 54

BESY 321-1BLO0-04A0

EES7 322-1BLO0-0AA0

== |||~ o

—|=

< Save and Campile >

a

The data are prepared for transfer to
the CPU using the menu command
Save and Compile.

Once you close the "HW Config"
application, the System Data symbol
will appear in the Blocks folder.

You can also check your configuration for errors using the menu command Station >
Consistency Check. STEP 7 will provide you with possible solutions to any errors which

may have occurred.

You can find more information under Help > Contents in
the topics "Configuring theHardware" and "Configuring
Central Racks."

6-2
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7 Downloading and Debugging the Program

7.1 Establishing an Online Connection

Using the supplied project "GS-LAD_Example" or the "Getting Started" project you
have created and a simple test configuration, we will show you how to download
the program to the programmable logic controller (PLC) and then debug it.

You should have:
¢ Configured the hardware for the "Getting Started" project (see Chapter 6)

¢ Set up the hardware according to the installation manual

Example of a series circuit (AND function):
Output Q 4.0 is not to light up (diode Q 4.0 lights up on the digital output module)
unless both Key 1 0.1 and Key | 0.2 are pressed. Set up the test configuration

below using wires and your CPU.

Power supply Operating mode Rack Programming
(on / off) keyswitch device with
STEP 7
software
Q4.0
J
]
L =
I
=]
Connection bridge Programming device
cable
STEP 7 Getting Started
7-1
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Configuring the Hardware

To assemble a module on the rail, proceed in the order given below:

ok

Attach the module onto the bus connector

Hang the module on the rail and swing it downwards
Screw the module in place

Assemble the remaining modules

Insert the key in the CPU once you have finished assembling all the modules.

You can still carry out the test even if you are using different hardware to that shown in the
diagram. You simply have to keep to the addressing of the inputs and outputs.

STEP 7 offers you various ways of debugging your program; for example, using the
program status or by means of the variable table.

7-2

You can find more information on configuring the
central rack in the manuals "S7-300, Hardware and
Installation / Module Specifications" and "S7-400 /
M7-400 — Hardware."

STEP 7 Getting Started
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7.2 Downloading the Program to the Programmable Controller

You must have already established an online connextion in order tp download the
program.

Switch on the power supply using the
ON/OFF switch. The diode "DC 5V"
will light up on the CPU.

Turn the operating mode switch to the
STOP position (if not already in
STOP). The red "STOP" LED will light

up.

Turn the operating mode switch to the
MRES position and hold it there for at
least 3 seconds until the red "STOP"
LED starts flashing slowly.

Release the switch and, after a
maximum of 3 seconds, turn it to the
MRES position again. When the
"STOP" LED flashes quickly, the CPU
has been reset.

If the "STOP" LED does not start
flashing quickly, repeat the procedure.

Downloading the Program to the CPU

Now turn the operating mode switch to
"STOP" again to download the
program.

STEP 7 Getting Started 7-3
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Downloading and Debugging the Program

rr”
d
SIMATIC Manager

5
B SiMATIC

= crus
BE@S

Ei=a
S SMATIC300 5

7-4

Start the SIMATIC Manager and open
the "Getting Started" project in the
"Open" dialog box (if it is not already
open).

In addition to the "Getting Started
Offline" window, open the "Getting
Started ONLINE" window. The online
or offline status is indicated by the
different colored headers.

Navigate in both windows to the
Blocks folder.

The offline window shows the situation
on the programming device; the online
window shows the situation on the

CPU.

Select the Blocks folder in the offline
window and then download the
program to the CPU using the menu
command PLC > Download.
Confirm the prompt with OK.

The program blocks are displayed in
the online window when you download
them.

STEP 7 Getting Started
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Switching on the CPU and Checking the Operating Mode

NP — Turn the operating mode switch to

RN — RUN-P. The green "RUN" LED lights

oo :’@ up and the red "STOP" LED goes oult.
The CPU is ready for operation.

When the green LED lights up, you
can start testing the program.

If the red LED remains lit, an error has
occurred. You would then have to
evaluate the diagnostic buffer in order

E to diagnose the error.

Downloading individual blocks

In order to react to errors quickly in practice, blocks can be transferred individually to the

CPU using the drag and drop function.

When you download blocks, the operating mode switch on the CPU must be in either

"RUN-P" or "STOP" mode. Blocks downloaded in "RUN-P" mode are activated immediately.

You should therefore remember the following:

« If error-free blocks are overwritten with faulty blocks, this will lead to a plant failure. You
can avoid this by testing your blocks before you download them.

* If you do not observe the order in which blocks are to be downloaded — first the
subordinate blocks and then the higher-level blocks — the CPU will go into "STOP"
mode. You can avoid this by downloading the entire program to the CPU.

Programming online

In practice, you may need to change the blocks already downloaded to the CPU for test
purposes. To do this, double-click the required block in the online window to open the
LAD/STL/FBD program window. Then program the block as usual. Note that the
programmed block immediately becomes active in your CPU.

You can find more information under Help > —
Contents in the topics "Establishing an Online
Connection and Making CPU Settings" and
"Downloading from the PG / PC to the
Programmable Controller."

STEP 7 Getting Started 7-5
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7.3 Testing the Program with Program Status

Using the program status function, you can test the program in a block. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN or RUN-P mode, and the program has been downloaded.

Gelling Started — C:ASIEMENSASTEP7\S7proi\Gettin_1 ONI @

=10/ x|

s
=] SIMATIC 300 Station
= cPuzlam E it F
= 57 Program(1) Fe1 DB1 DB2
23 [
it i it
SFC20 SFC21 SFC22
it it it
SFC26 SFC27 SFC48
it
SFCES
Debug

( v Monitar >

Debugging with Ladder Logic

"Green Light'

Open OB1 in the project window
"Getting Started ONLINE."

The LAD/STL/FBD program window is
opened.

Activate the function Debug >
Monitor.

The series circuit in Network 1 is
displayed in Ladder Logic. The current
path is represented as a full line up to
Key 1 (I 0.1); this means that power is
already being applied to the circuit.

Debugging with Function Block Diagram

Debugging with Statement List

~|[ruo] sTa| standard
A "Key 1" 1] 1]
A "Ke y:Z 0 0 1]
= "Green Light" 0 o 0 0

7-6

The signal state is indicated by "0" and
"1." The dotted line means that there is
no result of logic operation.

For Statement List the following is
displayed in tabular form:

— Result of logic operation (RLO)
— Status bit (STA)

— Standard status (STANDARD)

Using Options > Customize
you can change the way in
which the programming
language is represented during
testing.

STEP 7 Getting Started
A5E00069681-03



Downloading and Debugging the Program

5O m
OO000000

Soaramaa

OO0 0000

Seamramos

| "Fey_1" "Fey_2" "Green Light
{4}
L)

1 &
Key 17— "Green Light”
1 =
Key 2" —]
][ rro| sTa| standard
A "Key_1" 1 1 1]
A "Key_ 2" 1 1 0
= "green Light" 1 1 0

a

Now press both keys in your test
configuration.

The diodes for input 1 0.1 and | 0.2 light
up on the input module.

The diode for output Q 4.0 lights up on
the output module.

In the graphic programming languages
Ladder Logic and Function Block
Diagram, you can trace the test result
by following the change in color in the
programmed network. This color
change shows that the result of logic
operation is fulfilled up to this point.

With the Statement List programming
language, the display in the STA and
RLO columns changes when the result
of logic operation is fulfilled.

Deactivate the function Debug >
Monitor and close the window.

Then close the online window in the
SIMATIC Manager.

obtain a better overview.

We recommend you do not completely download extensive programs onto the CPU to run
them, because diagnosing errors is more difficult due to the number of possible sources of
an error. Instead, you should download blocks individually and then test them in order to

I Status."

I You can find more information under Help > Contents
in the topics "Debugging" and "Testing with Program

STEP 7 Getting Started
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7.4 Testing the Program with the Variable Table

You can test individual program variables by monitoring and modifying them. The
requirement for this is that you have established an online connection to the CPU,
the CPU is in RUN-P mode, and the program has been downloaded.

As with testing with program status, you can monitor the inputs and outputs in
Network 1 (series circuit or AND function) in the variable table. You can also test
the comparator for the engine speed in FB1 by presetting the actual speed.

Creating the Variable Table

The starting point is the SIMATIC
=2 wum ﬁ o o o Manager again with the open project
Ty | window "Getting Started Offline."
o Navigate to the Blocks folder and click
in the right half of the window with the
right mouse button.

i Use the right mouse button to insert a

. Variable Table from the pop-up menu.

Accept the default settings by closing
General - Parl 1 | General - Part 2| Atibutes | the uPrOpertleSu dla|Og box with OK.

Inzert Mew Object 3

Mame (intemal)

Symbok
Symbol comment

Project path: [

Storage locati
I i [EASIEMENS\S TEF7S 7pronGetin_1

Code Intertace

Date created: 121098121357
Last madified: 121098121357 121098 121957
Comment ’ =

A VAT1 (variable table) is created in
domoes i the Blocks folder.

= @ Double-click to open VAT, the
"Monitoring and Modifying Variables"
window will open.

E @ Geling Staried
Bl SIMATIC 300 Stalion
= cruzam
-39 57 Program(1)
{@ Source Files
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At first, the variable table is empty. Enter the symbolic names or the addresses for
the "Getting Started" example according to the illustration below. The remaining
details will be added when you complete your entry with Enter.

Change the status format of all the speed values to DEC (decimal) format. To do
this, click the corresponding cell in the header (the cursor will change to an arrow
over the Status Format column) and select DEC format using the right mouse
button.

%Val - [VAT1 -- (Getting Started\SIMATIC 300-5tation\CPU314[1]]]

ﬁ Table Edit Inset PLC ‘ariable “iew DOptions ‘wWindow Help _|ﬁ'|1|
Dl(@| @ Hlw@]-f [~ =ls]=] x| @l =) e
| Addre=ss |S§rmbol |M0nit0r FDrmathDnitor Valuelmodify Ualuel
I 0.1 "Eey 1™ BEOOL
I 0.z "Eey 2™ EOQOL
4.0 "Green Light' EOCL
Mir 2 "PE Actual Speed” DEC
DE1.DEW 6 |["Petrol™.Preset Speed DEC
Q 5.1 "PE Preset Speed Reached" BOOL
Juli} 4 "DE Actual Jpeed"” DEC
DLEZ.DEW 6 |"Diesel™.Preset Speed LEC
Q 5.5 "DE Preset Speed Feached” EBOOL
Press F1 for help. INS |Edit [141 7

| E| Save your variable table.

Switching the Variable Table Online

%l Click the ON button in the toolbar of
the "Monitoring and Modifying
Variables" window to establish a

connection to the configured CPU. The
word "ONLINE" will appear in the

status bar.
NP — Set the keyswitch of the CPU to
RN — RUN-P (if you have not already done
s S0).

STEP 7 Getting Started 7-9
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7-10

Monitoring Variables

Eﬁjnl Click the Monitor Variables button in
the toolbar. The operating mode of the
CPU is displayed in the status bar.

e [Henteor rogfe [Banitor va W Hedity valus

= Press Key 1 and Key 2 in your test
— i — i '\\ i i configuration and monitor the result in
the variable table.

The status values in the variable table
will change from false to true.
Modifying Variables

Enter the value "1500" for the address MW?2 in the Modify Value column and
"1300" for the address MWA4.

ﬁ\fal - [@BYAT1 - Getting Started\SIMATIC 300 Station\CPU314(1)\] ONLINE _ Al x|
ﬁ Table Edt Inset PLC ‘Varable “iew Options ‘Window Help _Iﬂlil
DlzlE| 8| $[mlelof s ==l c|o| x| wfe o s
| Address |S§rmbol |H0nit0r FDrmatlHDnitDr ValuelHDdify Valuel
I 0.1 "Eey 1" BOOL true
I 0.2 "Eey 2™ EOQOL true
4.0 "Green Light™ EOOL true
Juln) Z "PE Actual Speed” LEC a < ,
DE1.DEW & ["Petrol’™.Preset Speed DEC 1500
2 5.1 "PE Preset 3peed Reached™ BOOL false
nir 4 "DE Actual Spesd” DEC u} < )
DEZ.DEW 6 |"Diesel™.Preset Speed DEC 1200 —
Q 5.5 "DE Preset Speed Reached" BOOL false
Getting Started\SIMATIC 300-Station\CPL314(1] INS [ ONLIN| Monitar ’ﬁ o

KlA Transfer the modify values to your
_|| CPU.

STEP 7 Getting Started
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Following transfer, these values will be processed in your CPU. The result of the
comparison becomes visible.

Stop monitoring the variables (click the button in the toolbar again) and close the
window. Acknowledge any queries with Yes or OK.

&ﬁ\fal - [@VAT1 -- Getting Started\SIMATIC 300 StationACPU314[1]%] OMLINE _ Al x|
ﬁ Table Edt Inset PLC ‘Varable “iew Options ‘Window Help _Iﬂlil
D@l &) 3lele]of e =22 | x| @l o @64l e
| Address |S§rmbol |H0nit0r FDrmatlHDnitDr ValuelHDdify Valuel
I 0.1 "Eey 1" BOOL true
I 0.2 "Eey 2™ EOQOL true
4.0 "Green Light™ EOOL true
Juln) Z "PE Actual Speed” LEC 1500 1500
DE1.DEW & ["Petrol’™.Preset Speed DEC 1500
2 5.1 "PE Preset 3peed Reached™ BOOL true
nir 4 "DE Actual Spesd” DEC 1300 1300
DEZ.DEW 6 |"Diesel™.Preset Speed DEC 1200
Q 5.5 "DE Preset Speed Reached" BOOL true
E Getting Started\SIMATIC 300-Station\CPL314(1] INS [ ONLIN| Monitar ’ﬁ o

Very large variable tables often cannot be displayed fully due to the limited screen space.
If you have large variable tables, we recommend you create several tables for one

S7 program using STEP 7. You can adapt the variable tables to precisely match your own
test requirements.

You can assign individual names to variable tables in the same way as for blocks (for
example, the name OB1_Network1 instead of VAT1). Use the symbol table to assign new
names.

| You can find more information under Help > Contents
in the topics "Debugging" and "Testing with the
Variable Table."
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7.5 Evaluating the Diagnostic Buffer

If, in an extreme case, the CPU goes into STOP while processing an S7 program,
or if you cannot switch the CPU to RUN after you have downloaded the program,
you can determine the cause of the error from the events listed in the diagnostic

buffer.

The requirement for this is that you have established an online connection to the

CPU and the CPU is in STOP mode.

RUNP  —
RUN  =—

MRES e

(£ Getting Started -- C\SIEMENS\STEP7\S7proj\Gettin_1
=@ Gieting Stared
Bl SIMATIC 300 Stalion
= cruzam
£ 57 Progran(1]

FLC [

Diagnosing Hardware - Quick View

Path  [Getting Statec\SIMATIC 300 Staton\CFUSTTNST Frogam(1]

CPU / faulty modules:

Open Station Oniine.
Update
IV Display quick visw when diagnasing hardware
Closs Help

7-12

First turn the operating mode switch on
the CPU to STOP.

The starting point is the SIMATIC
Manager again with the open project
window "Getting Started Offline."

Select the Blocks folder.

If there are several CPUs in your
project, first determine which CPU has
gone into STOP.

All the accessible CPUs are listed in
the "Diagnosing Hardware" dialog box.
The CPU with the STOP operating
mode is highlighted.

The "Getting Started" project only has
one CPU which is displayed.

Click Module Information to evaluate
the diagnostic buffer of this CPU.

If only one CPU is connected, you can
guery the module information for this
CPU directly using the menu command
PLC > Module Information.

STEP 7 Getting Started
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The "Module Information" window provides you with information on the properties
and parameters of your CPU. Now select the "Diagnostic Buffer" tab to determine
the cause of the STOP state.

EMudule Information - CPU314 OMLINE - =] x|
Fath: IGetting StartedSSIMATIC 300 StationhCRUIT4[1 ST P CFU operating mode:  STOP
Srhatis:
Time System I Communication I Stacks
Gerneral M emarny I Scan Cycle Time
Events

STOF caused by stop switch being activated
12:32:30:890 pm 1012/98  Mode tranzition from STARTUR to BUN

2 S 3

3 1012498

4

] 12:32:30:890 pm 10412/98  Reguest for manual complete restart
g

7

a8

dalinon sy iy
12:32:35:780 pm

12:32:30:890 pm 101298 Mode tranzition from STOP o STARTUP
12:32:19:470 pm 1012/98  STOP caused by gtop switch being activated

12:32:18:090 pm 10/12/98  Mode transition from STARTUP to RUN ;I
Detailz on event: 1 of 20 EventID:  16# 4303
STOP caused by stop switch being activated ;I

Previous operating mode: STOP [internal]
Requested operating mode: STOP (intemnal)
Ihcoming event

Save fz... | Settings... K [ pem Elosh |D Help on Exent |

. The "Open Block"
Oowe | Wpawe | B | pitonis disabled,
because there was no
error in the block in the
"Getting Started"
project.

The latest event (number 1) is at the top of the list. The cause of the STOP state is
o displayed. Close all windows except for the SIMATIC Manager.

If a programming error caused the CPU to go into STOP mode, select the event and click
the "Open Block" button.

The block is then opened in the familiar LAD/STL/FBD program window and the faulty
network is highlighted.

With this chapter you have successfully completed the "Getting Started" sample project,
from creating a project through to debugging the finished program. In the next chapters,
you can extend your knowledge further by working through selected exercises.

You can find more information under Help > Contents
in the topics "Calling the Module Information."
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8 Programming a Function

8.1 Creating and Opening Functions (FC)

Functions, like function blocks, are below the organization block in the program
hierarchy. In order for a function to be processed by the CPU, it must also be
called in the block above it in the hierarchy. In contrast to the function block,
however, no data block is necessary.

With functions, the parameters are also listed in the variable declaration table, but
static local data are not permitted.

You can program a function in the same way as a function block using the
LAD/STL/FBD program window.

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

If you have worked through the
"Getting Started" sample project in
Chapters 1 to 7, open this now.

Mzer projects | Libre
: If not, create a new project in the
T SIMATIC Manager using the menu

< i # command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still

ﬂ_l carry out each step using a new
project.

Eelling Started -- C:\SIEMENS\S TEP7\S 7proj\G ettin_1 N aVIgate to th e B | oc kS fo | der and

ellmgslavled aion D D EI' .
e | 8D T 0 open it.
=1 57 Progiam(1)
= O o . .
Click in the right half of the window

o with the right mouse button.

STEP 7 Getting Started
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< Insert Mew Object , 3

Insert a Function (FC) from the
pop-up menu.

In the "Properties — Function" dialog
General - Part 1 | General - Par alls tibutes
- t”” '2'” | — box, accept the name FC1 and select
Lo — the required programming language.
Symbl, ' .. .
symbol commert. (o7 Confirm the remaining default settings
s | with OK.
of projest [Elemens\Giep? 5 7proN Gettin 1
Code Irterface:
Date created: 12.04.2000 130218
Last modified: 12.04 2000 130218 12.04.2000 130218
Camment: ’ :l
[]

&% Getling Started -- C:ASIEMENS\STEP7AS 7proi\GeMtin_1
Getting Started
=l SIMATIC 300 Station [ﬁ
=-[§] cPUR4)
-0 57 Program(1)
(@ Source Fies
o [

The function FC1 is added to the
Blocks folder.

Double-click to open FC1.

In contrast to the function block, no static data can be defined in the variable declaration
table for a function.

The static data defined in a function block are retained when the block is closed. Static data
can be, for example, the memory bits used for the "Speed" limit values (see Chapter 5).

To program the function, you can use the symbolic names from the symbol table.

You can find more information under Help > Contents in the
topics "Working Out the Automation Concept," "Basics of
Designing a Program Structure," and "Blocks in the User
Program."”

STEP 7 Getting Started
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8.2 Programming Functions

In this section, you will program a timer function in our example. The timer function
enables a fan to switch on as soon as an engine is switched on (see Chapter 5),
and the fan then continues running for four seconds after the engine is switched
off (off-delay).

As mentioned earlier, you must specify the input and output parameters of the
function ("in" and "out" declaration) in the variable declaration table.

The LAD/STL/FBD program window is open. You work with this variable
declaration table in the same way as with the table for the function block (see
Chapter 5).

Enter the following declarations:

Address |Decl. Hame Type Initial ValyComment
0.0|in Engine_On BOOL Zignal for switching on the engine
2.0|in Timer_ Function |TIMER Timer function used for the switch-off delay
4.0|out Fan_On BOCL Signal for switching on the fan

Select the current path for entering the
Ladder instruction.

Navigate in the Program Elements
catalog until you reach the element
S OFFDT (start off-delay timer), and
select the element.

s i s Insert a normally open contact in front
— D " @———  ofinputs.
Pl =2 Insert a coil after output Q.
.. R BCD-...
STEP 7 Getting Started 8-3
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Select the question marks and enter the corresponding names from the variable
declaration table (the # sign is assigned automatically).

Set the delay time at input TV of S_OFFDT. Here, S5T#4s means that a constant
has been defined with the data type S5Time#(S5T#), lasting four seconds (4s).

Then save the function and close the window.

#Tiwer Function

#Engine oOn S OFFDT #Fan_On
| | - Y |
1 = Q L) |
S5TH4s TV BIF...
..—R BCD. ..

8-4 STEP 7 Getting Started
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Programming the Timer Function in Statement List

#Engine_ On
S0THLS

#Tiwer Function
#Timer Function
#Fan_On

I o
]

If you are programming in Statement
List, select the input area below the
network and enter the statement as
shown here.

Then save the function and close the
window.

Programming the Timer Function in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below the
network and enter the FBD program below for the timer function.

Then save the function and close the window.

#Timer Function

S_OFFOT
#Engine On-—3 BIf...

SOTHELS — TV BCD ~...

#Fan_ On

E ... —R Q

In order for the timer function to be processed, you need to call the function in a block
which is higher up in the block hierarchy (in our example, in OB1).

You can find more information under Help >
Contents in the topics "Calling Reference Helps," [fu=
"The STL, FBD, or LAD Language Description,"
and "Timer Instructions."

STEP 7 Getting Started
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8.3 Calling the Function in OB1

The call for the function FC1 is carried out in a similar way to the call for the
function block in OB1. All the parameters of the function are supplied in OB1 with
the corresponding addresses of the petrol or diesel engine.

Since these addresses are not yet defined in the symbol table, the symbolic
names of the addresses will now be added.

An address is part of a STEP 7 statement and specifies
what the processor should execute the instruction on.
Addresses can be absolute or symbolic.

&% Getling Started -- C:ASIEMENS\STEP7AS 7proi\GeMtin_1

3P Getting Started

=3 SIMATIC 300 Station
=-[§] cPUR4)

E)-51) 57 Program(1

The SIMATIC Manager is open with
the "Getting Started" project or your
= = new project.

Navigate to the Blocks folder and
open OB1.

The LAD/STL/FBD program window
opens.

If you copied the symbol table from a sample
project (GS-LAD_Example, GS-STL_
Example, or GS-FBD_Example) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.

Adding Symbolic Names at a Later Stage

Open the symbol table from the LAD/STL/FBD program window using the menu
command Options > Symbol Table and use the scroll bars at the right-hand edge
of the window to scroll to the end of the symbol table.

Now add the following symbols to the symbol table:

Symbol | Address Data Type| Comment
DE_Follow_On T 2  TIMER Follow-on time for diesel engine fan
PE_Follow_On T 1 TIMER Follow-on time for petrol engine fan
Fan FC 1 FC 1 |Fan control
PE_Fan_On Q 5.2 [BOOL Command for switching on petral engine fan
DE_Fan_On Q 56 EOOL Cormmand for switching an diesel engine fan
8-6 STEP 7 Getting Started
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Programming the Call in Ladder Logic

B

. You are in LAD view. Insert a new
457 FC Blocks network (No. 6). Then navigate in the
Program Elements catalog until you
reach FC1 and insert the function.

. Insert a normally open contact in front
7.2 . of "Engine_On."

Engine_On

22,7 |Timer_Function

Using the menu command View >
Display >Symbolic Representation, you
can toggle between symbolic and absolute
addresses.

Click the question marks for the FC1 call and insert the symbolic names.

"Fan”
EN ENO

"PE_On" Fan Onf—"pPE Fan On"

I I Engine ©On

"PE Follow on'" —Timer Function

Program the call for the function FC1 in Network 7 using the addresses for the
diesel engine. You can do this in the same way as for the previous network (you
have already added the addresses for the diesel engine to the symbol table).

”Fan”
EN ENO

"DE_oOn" Fan On—"DE Fan On"

I I Engine On

"DE Follow On"™ —Timer Function

El Save the block and then close the
window.

Activate the menu command View >Display > Symbol
Information to view the information on individual addresses in
each network.

To display several networks on the screen, deactivate the menu
command View > Display > Comment and, if necessary View >
Display > Symbol Information.

Using the menu command View > Zoom Factor, you can
change the size of the networks displayed.

STEP 7 Getting Started 8-7
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Programming the Call in Statement List

Hetwork 6 : Controlling the Fan for the Petrol Engine If you are programming in Statement
e o ven onr List, select the input area below a new
Timer Punction: =B Follow on" network and enter the STL statements
- - shown here.
Wetwork 7: Controlling the Fan for the Diesel Engine
C;f;mjgg" g on Then save the call and close the
Timer Function:="DE Follow On" window.

Fan_On "DE_Fan_On"

Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area below a
new network and enter the FBD instructions shown below.

Then save the call and close the window.

fRan"

.. —EN

"PE On" —Engine_on Fan Onf="pg Fan On"
"PE Follow On" —Timer Function ENO—
"Ean"
.. —EN
"DE On" —Engine On Fan Ooni—"pE Fan on"

E "DE Follow on™ —Timer Function ENO |-

The call for the functions was programmed as an unconditional call in our example; that is,
the function will always be processed.

Depending on the requirements of your automation task, you can make the call for a
function or function block dependent on certain conditions; for example, an input or a
preceding logic operation. The EN input and the ENO output are provided in the box for
programming conditions.

You can find more information under Help >
Contents in the topics "Calling Reference Helps," =
"The LAD, FBD, or STL Language Description," or
"Program Control Instructions."
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9 Programming a Shared Data Block

9.1 Creating and Opening Shared Data Blocks

If there are not enough internal memory bits in a CPU to save all the data, you can

store specific data in a shared data block.

The data in a shared data block are available to every other block. An instance
data block, on the other hand, is assigned to one specific function block, and its
data are only available locally in this function block (see Section 5.5).

You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic
programming (see Chapter 3).

27 Getling Started - C:ASIEMENS\S TEP7\S TproitG ettin_1
=2 Getting Stated
=5 SIMATIC 300 Station
=- @ cPusld)
£ 57 Pogian(1)

STEP 7 Getting Started
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If you have worked through the
"Getting Started" sample project in
Chapters 1 to 7, open this now.

If not, create a new project in the
SIMATIC Manager using the menu
command File > "New Project"
Wizard. To do this, follow the
instructions in Section 2.1 and rename
the project "Getting Started Function."

We will continue with the "Getting
Started" project. However, you can still
carry out each step using a new
project.

Navigate to the Blocks folder and
open it.

Click in the right half of the window
with the right mouse button.
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Insert a Data Block (DB) from the
pop-up menu.

Rt Rl ey : In the "Properties — Data Block" dialog
box, accept all the default settings with
OK.

Use the "Help* Button for further
information.

The data block DB3 has been added to
the Blocks folder.

Double-click to open DB3.

In the "New Data Block" dialog box
which then appears, activate the option
Data block.

Close the dialog box with OK.

9-2 STEP 7 Getting Started
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Programming Variables in the Data Block

pdsere fime [iree Ditial valweeament.  Enter "PE_Actual_Speed" in the Name
s column.

=D.D‘ |END75TRUCT

Click with the right mouse button to
select the type using the menu
command Elementary Types > INT
from the pop-up menu.

In the example below, three shared data are defined in DB3. Enter these data
accordingly in the variable declaration table.

Address |Hame Type Initial Value |Comment
0. STRUCT
+0.0| |PE_Actual Speed INT a Actual speed for petrol engine
+2.0| |DE_actual Zpeed INT o Actual speed for diesel engine
+4.0| |Preset_Speed Reached |BOOL FALSE Eoth engines have reached the preset speed
=6.0 END_STRUCT

The variables for the actual speeds in the data block
"PE_Actual_Speed" and "DE_Actual_Speed" are treated
in the same way as the memory words MW2
(PE_Actual_Speed) and MW4 (DE_Actual_Speed). This
can be seen in the next chapter.

E Save the shared data block.
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Assigning Symbols

You can also assign symbolic names
to data blocks.

Open the Symbol Table and enter the
symbolic name "S_Data" for the data

block DB3.

If you copied the symbol table from a sample
project (zEn01_02_STEP7__STL_1-10,
zEn01_06_STEP7__LAD_1-10 or
zEn01_04_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.

Symbol | Address |Data Type| Comment

S Data DE 3 DE 3 Shared data block

El Save the symbol table and close the
"Symbol Editor" window.

Also close the variable declaration
E table for the shared data block.

Shared data blocks in the variable declaration table:

Using the menu command View > Data View, you can change the actual values of the data
type INT in the table for the shared data block (see Section 5.5).

Shared data blocks in the symbol table:

In contrast to the instance data block, the data type for the shared data block in the symbol
table is always the absolute address. In our example, the data type is "DB3." With the
instance data block, the corresponding function block is always specified as the data type.

You can find more information under Help > Contents in the topics
"Programming Blocks" and "Creating Data Blocks."
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10 Programming a Multiple Instance

10.1 Creating and Opening a Higher-Level Function Block

In Chapter 5 you created a program for controlling an engine with the function
block "Engine" (FB1). When the function block FB1 was called in the organization
block OB1, it used the data blocks "Petrol* (DB1) and "Diesel" (DB2). Each data
block contained the different data for the engines (for example, #Setpoint_Speed).

Now imagine that you require other programs to control the engine for your
automation task; for example, a control program for a rapeseed oil engine, or a
hydrogen engine, etc.

Following the procedure you have learned so far, you would now use FB1 for each
additional engine control program and assign a new data block each time with the

data for this engine; for example, FB1 with DB3 to control the rapeseed oil engine,
FB1 with DB4 for the hydrogen engine, etc. The number of blocks would increase

significantly as you created new engine control programs.

By working with multiple instances, on the other hand, you can reduce the number
of blocks. To do this, you create a new, higher-level function block (in our example,
FB10), and call the unchanged FBL1 in it as a "local instance." For each call, the
subordinate FB1 stores its data in data block DB10 of the higher-level FB10. This
means that you do not have to assign any data blocks to FB1. All the function
blocks refer back to a single data block (here DB10).

The data blocks DB1 and DB2 are integrated in
DB10. To do this, you must declare FB1 in the static
local data of FB10.

FB10
CALL FBL1 (for petrol engine)
CALL FBL1 (for diesel engine)

= e B
1r ST o

OB1
CALL FB10, DB10

"Petrol engine" data
"Diesel engine" data

FB1 D

"Engine"

T} &
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You should already be familiar with programming in Ladder Logic, Function Block
Diagram, or Statement List (see Chapters 4 and 5) and also symbolic

programming (see Chapter 3).

& Open |

|lzer projects | Librz

N/

=] Getting Started
= SIMATIC 300 Station
=- [ cruzta)
E)(5 §7 Progan(l)
ST

Properties - Function block

General - Pt 1 | Ganeraleisieles atibutes |
Name: ﬁ Gv Mull\ple\nslan:el:a;abl ;'
Symbolic Name

Symbel Camment:
Createdin Language

Prcject Path

Starage location
of project:

Date created:
Last modified:

STL [

[E Siemens\tenT S propGettin_1
Code

16/05/2000 03:48:27

16/05/2000 08:48:27

Interface

18/05/2000 0548:27

Comment ’ =]
I-]

[o]

If you have worked through the
"Getting Started" example in Chapters
1to 7, open the "Getting Started"
project.

If not, open one of the following
projects in the SIMATIC Manager:
ZEn01_05 STEP7__LAD_1-9 for
Ladder Logic,
ZEn01_01_STEP7__STL_1-9 for
Statement List

ZEn01_03 STEP7__FBD_1-9 for
Function Block Diagram.

Navigate to the Blocks folder and
open it.

Click with the right mouse button in the
right half of the window and insert a
function block using the pop-up menu.

Change the name of the block to FB10
and select the required programming
language.

Activate Multiple instance FB (if
necessary) and accept the remaining
default settings with OK.

FB10 has been added to the Blocks
folder. Double-click to open FB10.

You can create multiple instances for any function block, even for valve control programs,
for example. If you want to work with multiple instances, note that both the calling and the
called function blocks must have multiple instance capability.

You can find more information under Help > Contents in the topics
"Programming Blocks" and "Creating Blocks and Libraries."
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10.2 Programming FB10
To call FB1 as a "local instance" of FB10, a static variable must be declared with a
a different name for each planned call of FB1. Here, the data type is FB1
("Engine").
Filling out the Variable Declaration Table

The LAD/STL/FBD program window is open. Declare the following variables for

the FB1 call:
Address |[Decl. Hame: Type Initial ValiComment
in
0.0fout Preset Speed Reached EQOL FALSE Eoth engines have reached the preset speed
in out
2.0|stat Petrol_Engine "Engine” First local instance of FB1 "Engine”
10.0|stat Diesel Engine "Engine” Second local instence of FB1 "Engine™
0.0|temp PE_Preset_Speed Reached |EOOL Preset speed reached (petrol engine)
0.1|temp DE_Preset_Speed Reached |EOOL Preset speed reached (diesel engine)

The declared local instances will then appear in the
Program Elements catalog under "Multiple Instances."

Programming FB10 in Ladder Logic

Insert the call "Petrol_Engine" as the
multiple-instance block
"Petrol_Engine" in Network 1.

Then insert the required normally open contacts and complete the call with the
symbolic names.

#Petrol Engine

EN ENO
"dwitch Om PE" Engine Oni—"pgE On'
|| Switch_on -
Preset_Speed Reac| #PE Preset Speed R
"Switch Off_PE" hed eached
I} Switch Off
The "Actual_Speed" for the engines is not
"PE_Failure” _ taken from a memory bit (see Section 5.6
[} Failure onwards), but from a shared data block

(see Section 9.1). The general address
assignment is as follows:
"Data_Block".Address, for example:
"S_Data".PE_Actual_Speed.

"S_Data".PE_Actual
Speed —|actual Speed

STEP 7 Getting Started 10-3
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Insert a new network and program the call for the diesel engine. Proceed in the
same way as for Network 1.

#Diezel Engine

EN ENC

"Switch On DE" Engine On—"DE_On"

I I Suitch On

Preset_Speed Reac #DE_Freset_Speed R

"Switch Off_DE" hed Feached

I I Switch Off

"DE_Failure"
|| Failure

"S_Data".DE_Actual
Speed —Actual Speed

Insert a new network and program a series circuit with the corresponding
addresses. Then save your program and close the block.

The temporary variables
#PE_Preset Speed R #DE_Preset Speed R #Preset Speed Reac ("PE_Setpoint_Reached" and
eached eached hed "DE_Setpoint_Reached") are
| supplied to the output parameter
"Setpoint_Reached," which is
then processed further in OB1.

| ] | ] f
L

\
| [ [ 1 |

Programming FB10 in Statement List

CALL HPetrol Engine If you are programming in Statement
Switch On :="Switch On PE" . .

Switch OFF :="Switch OFF PE" List, select the input area under a new
Failuce ©7VPE_Failure? network and enter the STL instructions
Actual Speed :="3_Data".PE_Actual Speed

Engine On :="FE_On" ShOWn here

Preset_Speed Reached:=#PE_Freset Speed Reached

CALL #Diesel Ergine Then save your program and close the
gwitch On i="Zwitch On DE" block.

Switch Off ="Zwitch Off _DE"

Actual Speed :="3_Data".DE_Actual 3Zpeed
Engine_On r="DE_om"
Preset Speed Reached:=#DE Preset Zpeed Reached

Failure :="DE_Failure"

#PE_Preset_speed Reached
#DE_Preset_Speed Reached
#Preset_Speed Reached

[
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Programming FB10 in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under a
new network and enter the FBD instructions below.

Then save your program and close the block.

#Petrol Engine
. —{EN
"Switch On PE" — Fwitch On
"Switch oOff PE" —Switch Off Engine Onl="pE on"
"PE Failure" —|Failure Freset Speed Reac| #PE Preset ZSpeed R
hed —eached
"3_Data".PE_Actual
Speed —Actual Speed ENC |-
#Diesel Engine
. —{EN
"Switch On DE" —{Switch On
"Iiteh Off DE" — Switch Off Engine Onf—="DpE On"
"DE Failure" —Failure Preset_3peed Reac| #DE Preset Speed R
hed —eached
"% Data".DE_Actual
Speed —2ctual Speed ENO

#PE_Preset Speed R

eached —_ #Preset Speed Reac

hed
#DE_Preset Speed R =

E eached —_ —

To edit both calls for FB1 in FB10, FB10 must be called itself.

Multiple instances can only be programmed for function blocks. Creating multiple instances
for functions (FCs) is not possible.

You can find more information under Help > Contents in the u
topics "Programming Blocks," "Creating Logic Blocks," and
"Multiple Instances in the Variable Declaration Table."
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10.3 Generating DB10 and Adapting the Actual Value

The new data block DB10 will replace the data blocks DB1 and DB2. The data for
the petrol engine and the diesel engine are stored in DB10 and will be required
later for calling FB10 in OB1 (see "Calling FB1 in OB1" from Section 5.6 onwards).

Create the data block DB10 in the
Blocks folder of the "Getting Started"
20 =5 = = project in the SIMATIC Manager using
the pop-up menu.

iF
O To do this, change the name of the

data block to DB10 in the dialog box
which appears and confirm the
remaining settings with OK.

& Started
= (] SIMATIC 300Station
=-[ @ crudtdm
£ (5] 57 Frogan(1)
—— s

The data block DB10 has been added.
Block DB1D Open this block to view the "New Data
Pragramming taal: IDB Editar 'l BIOCk" dlalog bOX
— Create

¢ Data block

Activate the option Data block

" Data block referenci -defined data type R .
<_!° D ata block referencing a function block > rEferen cin g a fu n Ctl on b I oc k and

select FB10.

Beference:

Confirm the settings with OK.

Cancel Help |

the menu command View > Data

View.
< Diata Wiew >

Declaration YWiew

B2 - The data block DB10 is opened. Select

The data view displays each individual
variable in DB10, including the “internal”
variables of the two calls for FB1 ("local
instances").

The declaration view displays the variables
as they are declared in FB10.

10-6 STEP 7 Getting Started
A5E00069681-03



Programming a Multiple Instance

Change the actual value of the diesel engine to "1300," save the block, and then

close it.

Address |Decl. Hame Type Initial Value [Actual Value |Comment
0.0[out PrEsEt_SpEEd_REachEd EBOOL FALSE FALSE Both engines have reached
Z.0|stat:in PEtrﬂlﬁEnglne.Swit::hﬁOn BOOTL FALSE FALSE Switech on engine
Z.1l|stat:in PEtrﬂlﬁEnglne.Swit::hﬁOff BOOTL FALSE FALSE Switch off engine
Z.Z|stat:in PEtrﬂlﬁEng:Lne.Fsilure BOOTL FALSE FALSE Engine failure, causes thel
4.0|stat:in Petrol Engine.Actual Speed INT 1} 1} Actual engine speed
6.0|stat:out PEtrﬂlﬁEnglne.Engineion BOOTL FALSE FALSE Engine is suwitched on
6.1|stat:out PEtrﬂlﬁEng:Lne.PresetispeediRea::hed BOOTL FALSE FALSE Preset speed reached
8.0|skat Fetrol Engine.Preset Speed INT 1500 1500 Requested engine speed
10.0|stat:in DleseliEnglne.Swit::hion BOOTL FALSE FALSE Switech on engine
10.1|stat:in DJ.EsEl_EngJ.nE.SwJ.tch_Off EBOOL FALSE FALSE Switch off engine
10.2|stat:in DJ.EsEl_EngJ.nE.Fa.LlurE EBOOL FALSE FALSE Engine failure, causes the
1z.0|stat:in Diesel Engine.Actual Speed INT n] 1] Actual engine speed
14.0|stat:out DJ.EsEl_EngJ.nE.EnglnE_On EBOOL FALSE FALSE Engine is switched on
14.1|stat:out DJ.EsEl_EngJ.nE.Presat_SpEEd_REachEd EBOOL FALSE Preset spEEd reached
16.0|stat Diesel Engine.Preset_gpesd INT 1500 1300 uested engine speed

a

All the variables are now contained in the variable declaration table of DB10. In the first half,
you can see the variables for calling the function block "Petrol_Engine" and in the second
half the variables for calling the function block "Diesel_Engine" (see Section 5.5).

The "internal" variables of FB1 retain their symbolic names; for example, "Switch_On." The
name of the local instance is now placed in front of these names; for example,
"Petrol_Engine.Switch_On."

STEP 7 Getting Started
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You can find more information under Help > Contents in the
topics "Programming Blocks" and "Creating Data Blocks."
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10.4 Calling FB10in OB1

The call for FB10 is made in OB1 in our example. This call represents the same
function which you have learned while programming and calling FB1 in OB1 (see
Section 5.6 onwards.). Using multiple instances, you can replace Networks 4 and
5 programmed from Section 5.6 onwards.

Open OBL1 in the project in which you
have just programmed FB10.

Erz]
B SIMATIC 300Station
- crumgn

=] @g?ugvamg‘] FB1 DB1 DBZ
S Ei Ei E
o If you copied the symbol table from a sample
e project (ZEn01_01_STEP7__STL_1-10,

ZEn01_05_STEP7__LAD_1-10 or
ZEn01_03_STEP7__FBD_1-10) to your
"Getting Started" project in Chapter 4, you do
not need to add any symbols now.

Defining Symbolic Names

The LAD/STL/FBD program window is open. Open the symbol table using the
menu command Options > Symbol Table and enter the symbolic names for the
function block FB10 and the data block DB10 in the symbol table.

Then save the symbol table and close the window.

Symbal | Address |Data Type| Comment
Engines FE 10 FE 10 Example of multiple instances

Engine_Data DB 10 FB 10 |Instance data block for FB10 10

Programming the Call in Ladder Logic

Insert a new network at the end of OB1
and add the call for FB10 ("Engines").
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A5E00069681-03



Programming a Multiple Instance

Complete the call below with the corresponding symbolic names.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.

Then save your program and close the block.

"Engine Data"

"Engines"
EN ENO

Presst_Speed Reac| "5 Data".Preset Sp
hed reed_Reached

The output signal "Setpoint_Reached" for FB10
("Engines") is passed on to the variable in the
shared data block.

Programming the Call in Statement List

If you are programming in Statement List, select the input area under the new
network and enter the STL instructions below. To do this, use the FB Blocks >
FB10 Engines in the Program Elements catalog.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.
Then save your program and close the block.

CATTL "Engines" , "Engine Data”
Preset_Speed Reached:="3 Data".Preset_Zpeed Reached

STEP 7 Getting Started 10-9
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Programming the Call in Function Block Diagram

If you are programming in Function Block Diagram, select the input area under the
new network and enter the FBD instructions below. To do this, use the FB Blocks
>FB10 Engines in the Program Elements catalog.

Delete the call for FB1 in OB1 (Networks 4 and 5 from Section 5.6 onwards), since
we are now calling FB1 centrally via FB10.

Then save your program and close the block.

"Engine Data”

"Engines"
Preset_Speed Reac| "3 Data".Preset Sp

E ... —EN hed —eed Reached

ENC -

If you require additional engine control programs for your automation task; for example, for
gas engines, hydrogen engines, etc., you can program these as multiple instances in the
same way and call them from FB10.

To do this, declare the additional engines as shown in the variable declaration table of FB10
("Engines") and program the call for FB1 in FB10 (multiple instance in the Program
Elements catalog). You can then define the new symbolic names; for example, for the
switch-on and switch-off procedures in the symbol table.

You can find more information under Help > Contents in the —
topics "Calling References Helps," "The STL, FBD, or LAD
Language Description," and "Program Control Instructions."
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11 Configuring the Distributed 1/0

11.1 Configuring the Distributed 1/0 with PROFIBUS DP

Automation systems with conventional configurations have the cable connections
to the sensors and actuators inserted directly into the 1/0O modules of the central
programmable logic controller. This often means a considerable amount of wiring
is involved.

Using a distributed configuration, you can considerably reduce the amount of
wiring involved by placing the input and output modules close to the sensors and
actuators. You can establish the connection between the programmable logic
controller, the I/O modules, and the field devices using the PROFIBUS DP.

You can find out how to program a conventional configuration in Chapter 6. It
makes no difference whether you create a central configuration or a distributed
configuration. You select the modules to be used from the hardware catalog,
arrange them in the rack, and adapt their properties according to your
requirements.

It would be an advantage when reading this chapter if you have already
familiarized yourself with creating a project and programming a central
configuration (see Section 2.1 and Chapter 6).

Modular slaves:
for example, ET 200 M-IM153

Compact slaves:
for example, /0O modules
ET 200B-16DI / 16DO

PROFIBUS-DP network
between master and
slaves

Direct connection between
CPU and programming
device / PC via MPI

Master device:
for example, CPU 315-2DP

STEP 7 Getting Started
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Creating a New Project

e !Eu»z

Press F1 for help.

< ‘MNew Project' wWizard... >

STEP 7 Wizard: "New Froject”

Bl Which CPU are you using in your project? 214
CRU
= CPU-Typ [ Bestelir [=]
< CPU3I52DP BES7 315-26F01-04B0)
CPU name: [cruziszoF
MPI address: lﬁ
E = I — ﬂ
Preview<
) 57 Froz Block Name [ Symbolic Mams |
=l SIMATIC 300 Station ERYaR] Cycle Execulion
= §l cPU315 2P
=-i] 57 Program(1]
43 Blocks
< Back Mest > I Hake | Cancel Help |

Inserting the PROFIBUS Network

i =

SIMATIC 3001) MPI[T)

Ingert Mew Object »

PROFIBUS

| \L
|
[EE=] GG OF
& \MATIE 300(1) Bl !'-!

= [ cruis2op SIMATIC 30011) MPI(1)
-8 S7-Progiamm(1]
(@] Sourcs Fies

-2 Blocks

155 6S-DP - C:\Siemens' \STEP7\S7PROJAGS_DP

11-2

The starting point is the SIMATIC
Manager. To make things easier to
follow, close any open projects.

Create a new project.

Select the CPU 315-2DP in the
corresponding dialog box (CPU with
PROFIBUS-DP network).

Now proceed in the same way as for
Section 2.1 and assign the project the
name "GS-DP" (Getting Started —
Distributed 1/0).

If you want to create your own
configuration at this point, specify your
CPU now. Note that your CPU must
support distributed 1/Os.

Select the folder GS-DP.

Insert the PROFIBUS network using
the right mouse button in the right half
of the window.
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Configuring the Station

'E"?';ES'DP - CASiemens\STEF7AS7PRONGS_DP

Em=—
=455 SIMATIC 300 Staticr Eﬂﬂ
s farr e
e 57 Poganit] N\ L2OAE
(B Source Files
‘(g8 Blocks

gl

CPUN4I)

=
|l

CPU315-2 DP
DM

e
=-{E siMaTIC 300
{3 Ps-300

[+

=i SMATIC 300
202 sM-300
= DI-300

@ smzz DIzzOCa

=3 DO-300

al

SM 322 DO32DC24Y /0. 54

Select the folder SIMATIC 300 Station
and double-click Hardware.

The "HW Config" window is opened
(see Section 6.1).

The CPU 315-2 DP already appears in
the rack. If necessary, open the
Hardware catalog using the menu
command View > Hardware Catalog
or the corresponding button in the
toolbar.

Drag and drop the power supply
module PS307 2A into slot 1.

In the same way, insert the I/O
modules DI32xDC24V and
DO32xDC24V/0.5A in slots 4 and 5.

In addition to the CPU which supports the
distributed I/O, you can also place other CPUs in
the same rack (not described here).
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11-4

Configuring the DP-Master System

DP baster System

P3307 54 ok
CP|

PROFIBUS[1). DF Master System 1)

Azt

3
4 |[ Dlaz«DC24v

5 |[§ DO32DC24/DEL
B

B

|

=4

FROFIEUS-DP

Properties - PROFIBUS Node B-16DI DP

Geral  Parameters

Address =

Transmissian rate:1.5 Mbp

Subnet:

ot netwerked - TR
Fropetties
Delete

Ahbrechen Hilfe:

-4 PROFIBUS-DP
= ET 2008

B B-1601

Select the DP master in slot 2.1 and
insert a DP-master system.

You can now move any objects which you
place in the master system by dragging
them with the left mouse button held down.

Navigate in the Hardware catalog until
you reach the module B-16DI and
insert this module in the master system
(drag the object to the master system
until the cursor changes to a "+" sign;
then drop the object).

You can change the node address of
the module you have inserted in the
"Network Connection” tab of the
"Properties" dialog box.

Confirm the suggested address 1 with
OK.

In the same way, drag and drop the
module B-16DO onto the master
system.

The node address is automatically
adapted in the dialog box. Confirm this
entry with OK.
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=5 PROFIBUSDP
© B .

G @ M5

DIZZDC24Y
DO32xDC24Y/0 54,

=4 PROFIBUS-DP

{3 ET 200M

O3 IM153
=6 -
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Drag and drop the interface module
IM153 onto the master system and
confirm the node address again with
OK.

Select the ET200M in the network.
The free slots for the ET200M are
displayed in the lower configuration
table. Select slot 4 here.

The ET200M itself can have additional
I/O modules. Select, for example, the
module DI32xDC24YV for slot 4 and
double-click this module to insert it.




Configuring the Distributed I/O

Changing the Node Address

In our example, we do not need to
change the node address. In practice,
however, this is often necessary.

Select the other nodes one after
another and check the input and output
addresses. The "Configuring
Hardware" application has adapted all
the addresses, so there are no double
assignments.

Let us imagine that you want to
change the address of the ET200M:

Select the ET200M and double-click
D032xDC24V/0.4A (slot 4).

il B el ) Now change the input addresses in the

G "Addresses" tab of the "Properties"
dialog box from 6 to 12.
Close the dialog box with OK.
=

Finally, save and compile the
distributed 1/O configuration.

Close the window.
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Optional: Configuring Networks

-\Siemens' ASTEP7AS7PROJAGS_DP

o =

SIMATIC 300 MPI)
Shation

You can also configure the distributed
I/0O using the optional package
"Configuring Networks."

MATIC 300 Station
=-[@ cru3ts20P
E1 &0 57 Pragram(3)

PROFIBUS(1)

~ (B Source Files
{8 Blocks

Double-click the network PROFIBUS
(2) in the SIMATIC Manager.

The "NETPRO" window is opened.

You can drag and drop additional
DP slaves onto the PROFIBUS DP
from the catalog of network objects.

Double-click any element to configure
it. The "Configuring Hardware" window

E is opened.

Using the menu commands Station > Consistency Check ("Configuring Hardware"
window) and Network > Consistency Check ("Configuring Networks" window), you can
check the configuration for errors before saving. Any errors are displayed and STEP 7 will
suggest possible solutions.

You can find more information under Help > Contents in the topics
"Configuring the Hardware" and "Configuring the Distributed 1/0."
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Congratulations! You have worked through the Getting Started manual and learned the most
important terms, procedures, and functions of STEP 7. Now you can get started on your first
project.

If, while working on future projects, you are looking for specific functions or have forgotten any
of the operating instructions in STEP 7, you can use our comprehensive Help on STEP 7.

If you want to extend your knowledge of STEP 7, there are a number of specialized training
courses available. Your local Siemens representative will be happy to help you.

We wish you lots of success with your projects!

Siemens AG
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Appendix A

Overview of the Sample Projects for the Getting Started Manual

ZEn01_02_STEP7__STL_1-10:
The programmed Chapters 1 to 10 including the symbol table in the STL
programming language.

ZEn01_01_STEP7__STL_1-9:
The programmed Chapters 1 to 9 including the symbol table in the STL
programming language.

ZEn01_06_STEP7__LAD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the LAD
programming language.

ZEn01_05_STEP7__LAD_ 1-9:
The programmed Chapters 1 to 9 including the symbol table in the LAD
programming language.

ZEn0l1_04_STEP7__FBD_1-10:
The programmed Chapters 1 to 10 including the symbol table in the FBD
programming language.

ZEn01_03_STEP7__FBD_1-9:
The programmed Chapters 1 to 9 including the symbol table in the FBD
programming language.

ZEn01_07_STEP7__Dist_IO:
The programmed Chapter 11 with the distributed 1/O.

STEP 7 Getting Started
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