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1  Working with SIMATIC PDM

What are you going to learn?

The following practical exercise shows you how simple it is to create a network
configuration and subsequently process the devices in SIMATIC PDM.

In this sample you will create a SIMATIC PDM configuration with sensors. Later on,
you are going to work with a sensor (16 BAR) of the Siemens SITRANS P family.

Detailed instructions will lead you step by step through the creation of a network
and SIMATIC PDM operation.

1.1 Creating a Project

Starting the Program

Start the program with a click on the "SIMATIC Manager" desktop icon. An almost
empty window opens with a toolbar in the upper section (the number of icons in the
tool bar depends on whether you are using the integrated version or not).

K SIMATIC Manager M= E3

File PLC Yiew Option: ‘Window Help

D[] %] x|

Presz F1 ta get Help. i
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Working with SIMATIC PDM

Creating a Project
Proceed as follows in order to create a project:
1. Select the menu command File > New.

2. Enter a name for the project in the displayed dialog box. Verify that the option
"New project" is selected.

3. Confirm by clicking on "OK".

Mew |

|lzer projects | Libraries I

Mame I Storage path
SIMATIC_PO CASIEMEMSNSTEPTSS Y projhSimatic_

1] | 0

M arne: Type:

IPD W_1] Froject j
Storage location [path]:

IE:'&SIEMENSESTEF‘?&S?pmi Browse... |

k. I Cancel Help |

4. The task window "New project" is displayed. Double-click on the "networks"
icon in the right screen section. This transfers it to the left column.
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Working with SIMATIC PDM

Kl SIMATIC Manager - PDM_1
File Edit Inzet PLC Wiew Option: ‘Window Help
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'E!: PDM_1 [Process Device Metwork View] - C:ASIEMENSASTE ... M=l E3

455 iiaaii B2 retworks

Press F1 to get Help, L

Selecting the View in the SIMATIC Manager
You can choose between the following views in the Customize > View tab:
The Component View is used for configurations with HW-Config.

In the Process device network view the process devices are shown in groups
according to the network topology. You can configure networks and process
devices in this view. You can open this view for the configuration of the following
sample project by selecting View > Process device network view.

The Process system view gives you a fast overview of the configured process
devices. You can configure devices without linking them to a network.

Note: You can specify which view is to be displayed when the SIMATIC Manager
is started. If you configure via HW-Config we recommend you preset the
component view. You should preset the process devices network view if you use
the stand-alone version of SIMATIC PDM or if you configure the networks in the
SIMATIC Manager. Select the menu item Options > Customize and select the
desired view in the "View" tab.
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Customize

Languagel General  “iew |Eu:u|umns| .ﬁ.rchivingl

Diefault Project YWiew:

¥ Open new window automatizally on changing wiew

Process Device Plant Y iffid

Cancel Help

Configuring a PC

1.

1-4

Right-click on "networks" and select the context sensitive menu command
Insert New Object > PC.

The "PC" icon is now displayed in the right column. Shift it into the left column
with double-click.

Select the menu command Options > SIMATIC PDM > Define Current PC.
Caution: This step defines the current PC for use in the system from now on.

Right-click on "PC" and select the menu command Insert New Object... . >
COM Interface .
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Kl SIMATIC Manager - PDM_1
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Working with SIMATIC PDM

Setting the COM Interface
Proceed as follows to set the COM interface:

1. Mark the COM interface in the right column. Right-click to open "Object
Properties..." in the right screen section.

Propertiez of COM interface

2. Inthe "Connection" tab of the displayed dialog box, enter the correct
"COM-Port" (in our example "2").
Note: You should know which COM-Port is available on your computer.
Connect your MacTek HART modem or your Siemens modem to this port.

3. Confirm your entries with "OK".
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Working with SIMATIC PDM

Adding the HART Modem and Linking the COM Interface

1. Toadd a HART modem, right-click on the "Network" icon and select the menu
command Insert New Object... > HART modem.

2. Click on PC, mark the COM interface, right-click on "Object Properties..." and
select the HART modem in the "Network" tab.

Properties of COM interface

HART modem

3. Confirm your entries with "OK".
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Working with SIMATIC PDM

Inserting HART Devices

You can insert up to 16 devices per project using the standard version of SIMATIC
PDM. If you need to configure more devices than that for a project, you can
purchase expansions for an unlimited number of devices.

To insert the desired HART devices, proceed as follows:

1. Right-click on the HART modem and in the context sensitive menu select the
command Insert New Object... . > HART Device .

2. The dialog box "SIMATIC PDM Insert Object(s)" is displayed.

K SIMATIC Manager - PDM_1 = |0] x|
RN SIMATIC PDM Insert object(s)

n]=

Mame:  [HART_1 =]

. ||:| Start value increazed from 'Short adregs" [0 15].
B [The start vwalue iz automatically increazed.]

7| futomatic subnet configuration
[T} futomatic device recognition

¥ Create diagnosiz

How many "HART device-objectz should be created? IE j

Autharization-nfo: 0 of 4 authaonzed TAGz projected

] Cancel Seleat | Help |

Press F1 to get Help, | | |

1-8

3. Inthe "Name" field, enter the desired name (maximum 8 characters) for the
HART device (in our example HART_1). Enter "2" in the field "How many
"HART device" objects should be created". You do not need to make any
entries in the field "Start value increased from "Short address", because the
program automatically enters this value.

4. Confirm your entries with "OK". The program inserts two sensors named
"HART_1 1" and "HART_1 2" in the project. They are inserted into the right
column. Their name numbers are automatically incremented by one count.

5. Double-click on the new device you have created. The dialog box "SIMATIC
PDM Device Selection" is displayed. Select the type of your HART device. If it
does not exist, click on the "Catalog Import..." button and browse through your
CD-ROM drive to the subdirectory HCF-DD. Then select your HART device
type in the "HCF" directory.
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Working with SIMATIC PDM

6. Confirm by clicking on "OK".

Note: Importing may take several minutes. All current HART device information
(.DDLs) is imported. You can download updates from the following Siemens
Website (status May 2000):

http://www.feldgeraete.de/76/produkte/simatic_pdm/infos.html

7. Following this import, the dialog box "SIMATIC PDM Device Selection"
displays the installed HCF files.

SIMATIC PDM Device Selection |

HART-Device Catalogue: 758 entriez [440 devices]

= HCF

- BA

-DM

1

Dezcription;

Order Ma.:

-- ACCUTECH [ID: Dx005e]
(- AMDERSON [ID: 0x0054]
- APPARATEBAU_HUNDSBACH [ID: 0x0071]

-BESTA [ID: 0=0086]
-BOPP_AND_REUTHER_HEIMRICHS [ID: 0=006c)
-BROOKS_INSTRUMEMT [ID: 0=0004]
-BURKERT [IDv: 0=0073]

-DELTA [ID: 0x000e]

-DRAEGER [ID: 0=0052]
-DREXELEROOE. [ID: 0x004e]
-DYMISCO [ID: 0=0072]
-ECKARDT [ID: 0=003f]
-EMDRESS_HAUSER [ID: 0=0071]
-FLOWSERVE [ID: 0x0030]
-FOXBORD [ID: 0x0014]

- FLUJTID: 0x0015] LI Catalog-lmport ...

B

Cancel |

LEY _FISCHER_aAWD_PORTER [ID: 0=0012]
Hep |

C[ID: 0x0074]

Device praofile for actuator

SIMATIC PDM V5.1 Getting Started

A5E0096773-01

1-9


http://www.feldgeraete.de/76/produkte/simatic_pdm/infos.html

Working with SIMATIC PDM

Selecting a Sensor
Proceed as follows:

1. Double-click on one of the sensors which you have inserted (in our example
HART 1 1).

2. Select the entry Sensors > Pressure > SIEMENS > SITRANS P-DS >
Pressure > 16 Bar to choose the sensor you have created. Configure the
other devices you have selected for your sample project correspondingly.

SIMATIC PDM Device Selection |

HART-Device Catalogue: 758 entriez [440 devices)

= Sensors ;I |
[+~ Flow

0K |

" L,aw.al i Caricel |

[+ Liguid &nalysis

- Pressure

- ABB Kent Taplor

- SIEMENS Help |
=l Sitrans P-DS

-- Abzolute Pressure [Differential Pressune)

-- Prezsure [Sere Pressure)

[ Differential Pressure

[ Level

[1- Pressure

L d00 Bar LI Catalog-lmpait ...

Dezcription; teazuring zpan to 16 bar

Order Mo TR F A2 # [y wees

3. Confirm all entries with "OK".
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Working with SIMATIC PDM

1.2  Setting the PG/PC Interface for PROFIBUS
Communication

Whenever you create a PROFIBUS network, you should also check the PG/PC
interface to insure that no PROFIBUS device configuration has been created by
another user. Proceed as follows:

1. Select the menu command Options > Set PG/PC Interface (in the stand-alone
version you can find the PG/PC interface in Start > Settings >Control Panel).

2. Inthe dialog box, verify that the option "<None>" is highlighted in the dialog
box. Select the CP installed in your device.
Note: The "Set PG/PC interface" function becomes important if you want to
create a PROFIBUS PA system and configure PA devices. SIMATIC PDM can
be used both for HART or PROFIBUS systems, however, with different
hardware (for PROFIBUS systems, for example, you need a Siemens CP5611
or 5511 board or another appropriate board).

Set PG/PC Interface
Access: Path |
Aeocesz Paoint of the Application:

[S7OMLINE  [STEP 7) =]
[Standard for STEP 7]

Interface Parameter Azzignment Uzed:
|<N|:une> Eioperties,.. |

B <Manes -
CP5411(Auta)]
CP5411 [Pl Eeru |

CPE411[MPI] DEEE
B3 CP5411(PROFIBUS) ;I .

|nterfaces
[ Ade/Pemave: Select.. |

Cancel | Help |

3. Confirm your entries with "OK",
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Working with SIMATIC PDM

1.3 Configuring a Device
Double-click the device icon to start SIMATIC PDM. Select the option "Specialist”

or "Maintenance engineer" in the displayed dialog box. Confirm your entries with
"OK". The SIMATIC PDM logo is now displayed.

MATIC SIMATICPDM |
Tha Brarcce MNaviea anager
é Uszer IM

% aintenance engineet

=
" Specialist Caticel |

214

Easswond Help

Copyright SIEMENS AG 2 1337 - 2001

You have now opened SIMATIC PDM for your selected HART device. The values
displayed in the right screen section do not represent "real" values, but rather the
values in the DDLs selected by you. To obtain the correct values for your device,

select the menu command Device > Download to PG/PC or click on the toolbar

icon.
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F SIMATIC PDM HART_1 2 |_ O] x|
File Device “iew Optiohz Help
H| & | 3| W2
B- SITRAMS P DS Parameter Valy =~
- Input - -
I:I Output » ldentification
(-1 Human Interface » » Operation Unit
o[ Diagnosiz Settings | | TAS HART 12
#-[77 Mechanical Constr . =
[T Certificates and Apy Descriptor
Message
» » Device
Manufacturer SIEmens
HART Device D ]
Device Type SITRANS P Ds
Distributor Siermens
Device arder number FMFA033-1 0400
Lniversal Revision 5
Device Revision 1
Software Revision 1
Hardware Revision 1
Final Assembly Number 1
sensor Type Gauge (GF)
Sensor Serial Mumber 1]
Date 01.10.98
» Input x
| KN | b
Update... \Maintenance Mo connec! | | | o

Caution: Before you submit data to a device you should download the current
device data to your PC and create a software link to the HART device via HART
modem. Select the menu command Device > Download to PG/PC or click on the
corresponding toolbar icon. The on-screen values are replaced by the real values
of the device. In the status bar the status changes from "Not connection” to
"Connected". If you now edit these values, their status changes from "Initial value"
to "Changed". To transfer data to the sensor, select the menu command Device >
Download to device or click on the corresponding toolbar icon. All previous
sensor data is overwritten with your edited data. Therefore, verify all data before
you transfer it to the device.

Note: It is possible that the HART device has not been implemented in your
SIMATIC PDM version. If this is the case, download the current software version or
up-to-date Service Pack via via Internet.
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Working with SIMATIC PDM

Congratulations! You now have worked through this "Getting Started" and
become acquainted with important terms, procedures and functionalities of
SIMATIC PDM. You are now ready to create your first project.

If you encounter problems finding information on certain functions or operating
sequences for SIMATIC PDM, you are welcomed to take advantage of our
extensive Help on SIMATIC PDM.

We wish you a lot of success with your future projects!
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